Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Vega 64 - 54MH/s with less than 130w

lower mem or higher rcdrd in the straps
maybe your vdd might be too low too for that particular card


Nice! looks like it runs fine at 1050. That’s cool thanks!

1 Like

Here my vega´s Asus 56 is flashed from 64, rest oem 56. I belive i could go higher with some, but for now im happy with these.Maybe ot, but what do u guys recommend for 56 hynix mem? Looks like im getting some invalids wit 1075, perhaps should go to vdd 340. Happy with these my first vegas, great value.

i was so so tempted to buy one vega 64 and sell my two 580 8gb in exchange but i did not

as your setting vega taking actual on the wall 180 watt is not 110 or 130 watt did you check on the watt meter

and my two 580 8gb card give 64mh take on the wall 220 watt which is i find it good
Don’t believe what software show you

my whole system taking 900 watt . 80 watt system alone taking

i havent check individual gpus, but sure, i have watt meter on the wall and i have adjusted hive settings to match actual draw from the wall. im pulling with 2 rigs in total 2485W, if i keep hive settings power settings, the reading is way different. Like my rig 1 is showing 1103w combined draw of gpus on that one on gui is 688w+there will be more than 100w from motherboard and psu effiency lost, fans etc…so its may be around 850-900 w according hive, but the total draw is adjusted in hive settings with watt meter so actual draw match wath hive is showing. Havent really been thinking about single component draw, just total. I belive its well known fact that hive is showing consumption wrong…or am i missing your point here?

@0Lucifer0 Just created an account to thank you mate!

Just got myself a PowerColor RX Vega 64 and have tried numerous settings but never got it to work as well as my Asus Strix RX Vega 56…I would get close (around 50-51) but it was never stable.

I force flashed it with the PowerColor 56 firmware and applied your straps and timings and now it performs exactly like yours. Now I have to test them both on the same rig and see if they will both maintain these hash rates. Just for the record, I am using the latest version of Teamredminer (I think it’s

EDIT: As I was writing this, the rig crashed - approx 1 hour after applying these lol.

In any case, you have set me on the right path and I am experimenting around these values. I am currently using Core: 1050 VDD: 850 MEM: 1000 to see how it goes. These settings coupled with your straps are giving me 52.90-53.00

The important thing to note - and this is something that I have seen in many videos and I have experienced first hand - is that these settings do not work from a cold boot, at least for me.

I have to:

  1. Unset the flight sheet and the OC settings before booting up the rig so it doesn’t start anything.
  2. After it boots up and it’s idle, I enter the straps through the command line (amdmemtweak --gpu 0 –CL 20 --RAS 26 --RCDRD 12 --RCDWR 12 --RC 38 --RP 12 --RRDS 3 --RRDL 5 --RTP 6 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 24000 --RFC 239)
  3. I apply the flight sheet and let the card start hashing with default settings for a couple of minutes
  4. Apply the OC

If I do a cold start with OC’ed settings, my card goes into a frenzy and stops working for 10-15 minutes.
If someone knows a way to overcome this, please feel free to chime in. I am relatively knew to this, so any info helps.

1 Like

you can now use the advanced settings to set up the amdmemtweak so do not have to command line anymore

1 Like

@0Lucifer0 Yeah, I saw that a tweak → advanced config option was available but in some of the videos I had watched, I saw them enter it manually and thought maybe it worked better if you enter it like that.
That’s very helpful to know, it is however irrelevant to the fact that I cannot cold boot with these overclocks, for example after a restart.

Do you have a way to circumvent that?
Does teamredminer have a command to apply OC after the dag regeneration like TREX has for nvidia cards (“dag-build-mode”:“2”)?

And just for the record, card is chugging along perfectly with my slightly lower clocks and voltages, now @52.98MH.

My only problem would be what I asked above, so I don’t have to go through the rigmarole every time I want to reboot. Again, many thanks!

Heya, struggling with my rig, keep ending having some message like

[  383.238611] amdgpu 0000:10:00.0: amdgpu: failed to read reg:ecc5

Is it normal ?
I can’t reset the card, and have to reboot eveyr time, is it the only way ?

Also it is image
Is it needed to flash to 56 ? and I just tech one similar from techpowerup ?

It does the tweak on startup amdmemtweak should be run on startup once not when the miner is already running

@_viktor I don’t know which model exactly your cars is but yes, cards are way more stable if you flash them with the same make and model RX Vega 56 bios. Especially if the card has dual bios, you have no risk.
At first, I got a Subsystem ID mismatch, so I had to force flash it. Waited a couple of minutes to make sure, then restarted the PC and it saw it as an RX 56.

I wrote what procedure works for me and it’s been running for a sold day with no hickups.

Good luck!

Yes, I understand that and thanks for the reply.

The problem I mentioned isn’t the straps, it’s the core and memory settings you mention in your post.
The card will not apply such high setting upon first boot / restart.
If I start it with default settings and apply the overclocks after a minute, they work just fine, as you can see below.

My only question was - for someone who might know - is if teamreadminer has an option to delay applying the overclocks.

It did work in the end. I also fixed my stability issue (not sure how tho). And now it is running smoothly almost, the Asrock is moody, but no invalid shares since some hours now, so I will settle on ~47 Mh.

It definitely seems like your straps are not applied I recommend to use the new amdmemtweak directly in the oc parameters

I do not claim to be an expert by no means, I owe my good hashrate to @0Lucifer0 's post.

My reply is based on reading multiple posts and watching multiple videos in my search for the most optimized hashrate. It is also based on a lot of trial and error, including a lot of nerves and swearing hahahaha

First things first. You initial post referred to a problem you had with a Vega 64. I am assuming that you flashed it and the flash worked, as suggested, right?
Are all your other cards 64’s flashed to 56? In general (and this is not absolute), you can run your memory a bit higher on the 64’s flashed to 56 but that depends also on the silicon. Obviously not all cards are created equall. The good thing is that you are running all 56’s. I have read that it makes for a stabler rig.

I am assuming that the reason why your ASRock is moody is because you have applied straps that work best on cards with Samsung Ram, your ASRock has Hynix…

Stop the worker, apply these straps below through your command console:
amdmemtweak --gpu 2 --cl 18 --ras 23 --rcdrd 22 --rcdwr 11 --rc 34 --rp 13 --rrds 3 --rrdl 4 --rtp 6 --faw 12 --cwl 7 --wtrs 4 --wtrl 4 --wr 11 --rfc 164 --REF 15000

Start the worker again with your existing clocks and slowly try to match the clocks you use on the other cards.

I am getting the following on my flashed 64 - runs without a hitch 24/7. Same on my Asus Strix 56

I would suggest trying 1000, 840, 1000 on all cards after you have let them run for a couple of minutes. I don’t think that the Hynix cards will do as well as the other but you will see. If you have trouble, just revert back to the ones you are using now (1000, 850, 950). Good luck!

@0Lucifer0 If he has applied the staps through the command line and not through the tweak/add config section the icon will not show up. You can see that also in my screenshot above. Or maybe he hasn’t applied them, don’t know…

1 Like

Memory doesn’t run higher on 64 flashed to 56 it run lower but get better hash rate.
Those straps are only for Samsung but I’m surprise because Vega 64 were not suppose to have any Hynix only 56 have those from my understanding

1 Like

Memory doesn’t run higher on 64 flashed to 56 it run lower but get better hash rate.

Didn’t know that, thanks for the tip! I didn’t think so cause my flashed 64 and my original strix 56 give the same hashrate with the same overclocks.

I’m surprise because Vega 64 were not suppose to have any Hynix only 56 have those from my understanding

Maybe it’s Hynix cause it’s an original Vega 56 and not flashed.

That’s the issue my tutorial is only for Vega 64.

Finally found the best hash with no or less invalids

amdmemtweak --CL 20 --RC 37 --RP 11 --WR 14 --CWL 8 --FAW 12 --RAS 20 --REF 65535 --RFC 248 --RTP 5 --RRDL 6 --RRDS 3 --WTRL 9 --WTRS 4 --RCDRD 12 --RCDWR 12

Volt:830 (if keeps rebooting/dead, play between 840-870)

These are vega 64 flashed with vega 56 Bioses.
TIP: use the vega 56 bios that has voltage between 220-260.
dont use the 120-180 or 280-320 as it will cause to reboot during OC application.

Happy Hashing. (Don’t be afraid to flash your vega 64 to vega 56 Bios) it’ll be the best decision you’d ever make for mining.


Thanks for this @akosi .
What vbios are you referring to? I just flashed the same model’s RX 56 vbios for my RX64 card (Powercolor Red Devil).
Also, will these straps/oc’s work for normal RX56’s? I am asking because I have also managed to get 55-56 on both cards but they are not 100% stable.