Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Error: connection to api server failed

Hi. I’ve problems to connect the rig to internet after set Rig ID and Password.
I try using “net-test” command and all the connection FAILED.

Can you help step by step?


I have same problem on my 4 rigs. It just happens yesterday and I did not see any error message before. I use HINE POOL and Phoenix miner. Any internet connection can not be seen while using fire fox browser. I thought my rig was broken.
Anybody help us. please!


Same here since last night.
net-test shows errors
check firewall or connection setting…

running dnscrypt -i && sreboot also error

please advice

Problem solve.
Writing “dnscrypt -i” screen show how hiveos try to install a “dns driver” using internet connection. Then fail but show the url and file name to download.

Save .deb file into a USB memory and use linux commands to mount and find file can install .deb file

how do you tell script to get the file from that directory?

1 Like

Got to do the same thing, still getting an error check DNS or connection settings

First question is wether it is site or the setup.

Try ping (Google server)
If no response, network issue (No connection)
If get respose try
lookup (dnslookup/dig or similar google->IPaddress)
If no response, network issue (DNS server)
If get respose try
Try setting the DNS to (Google DNS server)

Hopefully it will work then…

1 Like

Ok, the problem is beyond strange.

  1. I have connection - VERIFIED, plugging same eth cable on windows pc it works.
  2. Tried 2 different miners, same issues
  3. Tried 2 different OS instances, same issue.

Pining from windows based pc works, pinging anything from hive OS, both miners does not!

Check Hiveos statsus. It is a webpage. Then you can see the server statuses.

The last couple of days they have been unstable for me… Up and down from time to time…

hello, sorry to bother you, i just encounter this same problem but i dont know how to install the deb file, is there any way you can help me how to install it

Hi andrewdays can you please tell me how do you fix the problem?

I have the same problem. It is still not fixed.


Not to familiar with Linux, so I was wondering if i can get a step by step instructions on how to fix this issue?

  1. how do i save deb file to usb

  2. how do i mount/find the file so hive can install it?

  3. And any other steps taken to solve this issue


i was able to download the file from my windows laptop from the url unto a usb drive. I inserted it into my linux rig but i’m stuck there. I don’t know how to mount in linux

If someone can help with this, that would be great.

update: i simply swapped out my wifi doggle and it worked. I also created a new worker in the process, so I’m sure if that helped at all

I bought the wifi extender in the second picture (tp-link model number TL-WA850RE) and connected an ethernet cable to it. This solved my issues completely with firewall, couldn’t connect to api, curl issues and more. Hiveon didn’t list a link or model number, but here it is! tp link TL-WA850RE

Please, does anybody know what are the correct linux command after I insert the USB flash disk with the .deb file to install the file?

1 Like

I had this error instant on first run, and i could fix it on two rigs with put the following text into the rig.conf

“# Find out your hash in farm’s settings on the web”
“# The rig will autoregister itself in your account after the first run”

and Enter Farm_Hash, found in the Rig Settings. *without the “”

Take your phone and your charging cable and use ththering via usb when ththering is on use this on the command line:

ifconfig usb0 up && dhclient usb0

after this is done test that network is working.


after this proves you have some kind of connection use this:

dnscrypt -i

then reboot and test if it is working correctly


I personally didn’t get this working either way got connection might work on some boards but not mine found youtube video telling that some mobos have 2.5GB like mine did (Asus ROG Strix B550-F non wifi) and problem is that there is no native support for 2.5GB nor 5.0GB ethernet. beta build natively supports up to 5 GB ethernet connection which allowed me to use hiveos as it should be like.

Hope someone finds help from this and please if this doesn’t work for you let everyone know on this thread.


Got the same problem after troubleshooting and reading almost every forum on google discovered that my isp blocked hive os servers :sweat_smile:

Gotta find a workaround for using a vpn…THIS SUCKS! :pensive:

1 Like