Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Custom Miner Integration

hello, 6 * rx580

Hashrate suxx. What settings do you applied?


I’ve somewhat done the custom integration for the xpmclient for my rigs but the HiveOS dashboard doesnt recognise the algorithm as valid and displays it as “unknown” (ive tried PrimeCoin and Cunningham to test ). Also CPD is not yet recognised as a unit in Hive platform so “hs” is used as replacement instead and it works. Other than that it works fine with my nvidia cards… havent tried it with AMD yet…

and finally, no i havent released it but i am sure it will be released by Hive devs at some point…

You should add the name of algo as “algo” param in stats.

Just give it in KHs/s. Multiply or divide your value to get it in KHs/s.

# make JSON
  stats=$(jq -nc \
        --argjson hs "`echo ${hs[@]} | tr " " "\n" | jq -cs '.'`" \
        --arg hs_units "$hs_units" \
        --argjson temp "$temp" \
        --argjson fan "$fan" \
        --arg uptime "$uptime" \
        --arg ac "$ac" \
        --arg rj "$rj" \
       --arg algo "$algo" \
        '{$hs, $hs_units, $temp, $fan, $uptime, ar: [$ac, $rj], $algo}')
  # total hashrate in khs

@ ATrump
Totally agree with you

BTW hamednik
In 2.0 we added XMP as coin (without miner and pool configuration yet)

FinMiner moved to its own topic:

1 Like

XMP or XPM ???

if XPM , then tomorrow I will try to mine …

sorry misspelling ))
[XPM] PrimeCoin

        "name": "prime",
        "coins": [


Объясните пожалуйста что я делаю не так?

I would appreciate a little help. I’m trying to integrate tdxminer using the custom miner feature. I’ve set up the custom wallet. Using SSH to get to the console, I see that that tdxminer seems to be working fine, but the stats don’t show up in the Hive OS GUI. What do I need to do to get the stats in Hive? Detailed steps would be helpful as I’m very new to Linux.

miner = t-rex
без номера версии или баг

Use template at bottom of Wallets page “GIN custom” as example. tdxminer already integrated via feature “custom miner” with control & stats

Thank you for your quick reply. I did use the “GIN custom” template when I set up this rig. I checked the setup again to confirm it was configured properly. I got the same result - I could see the rig mining by looking at the SSH console, but did not see hash rate stats on the HiveOS GUI. Adding a second GPU seem to have fixed the problem.

This rig is a new rig that I am testing. So, I only had 1 GPU attached. But, when I added a second GPU, the stats showed up on the Hive GUI. Is it possible that the integration won’t pass the stats to Hive when there is only 1 GPU (GPU 0)?


i didn’t tested a lot, this hashrate is with stock settings and no OC.

I think you’re referring to the avail_algo array in the h-stats script and i’d just done that which produced the “unknown” algo results.

I see that the json sent to the Hive API gets the algo from the “get_miner_algo()” function which in turn irritates through the algo array where i’ve initially put the algo name…

Unless there its another parameter you’re referring to, thats all i see thats feeding the algo name back to the Hive…

no multiplication needed as when hs is used results are accurately displayed along with totals… however the actual units Kh/s as opposed to CPD is missing… I guess im being a perfectionist :wink:

Just as i suspected there are wheels in motion to get this minor released soon i guess :wink: I wont bother with releasing my custom integration then and will leave it to you guys…

It’s another question how to get algo name. There can be many ways, you can look it in config, parse log or get it from API. For miners with only one algo you can just hardcode it.

Hello !

Can someone make a custom for Bminer ? it would be awesome :

Hashrates looks great :

Thank you

This is not necessary because it is present in the main interface.
bminer and lolminer updating will happen after the release of Hive 2.0 because need to make interface changes for this miners

Oh sorry didn’t saw it, thank you for your response