Increase your income with Hive. Invite your friends and earn real cryptocurrency!

BTC B250C HiveOS Help


I have recently been trying to use a BTC B250C (ver 1.2) with HiveOS. Ive been running into an issue where anywhere between 1-72 Hours after booting up the system will randomly and totally crash. Lights will still be on for the board, ethernet, etc. The GPUs will still spin fans and run as if the system is on. However, the system shows as having no connection to HiveOS. This is typically preceeded by a n increase in LA but nothing extreme. I have been searching all over the internet and seen people with similar issues related to this board. I have tried both G3900 and 6500 intel CPUs. I have tried multiple sticks of DDR4 2133/2400 RAM. My assumption is that its a defective board but I want to know if there are any known issues between BTC B250C and HiveOS. What, if any, fixes for this issue are there Additionally, any recommendations for a different 12 GPU board would be appreciated. I’m tempted to just buy another board with full kit (cpu, ramm, cooler) of an earlier version such as the ones that dont use usb (pcie x1) or with usb but have one pcie port and the soldered PCIE Power plug still.

Ive seen that the recommended CPUs are G3900 or G4400.
I’ve seen that for HIveOS the recommended RAM is 4GB of 2133/2400/2800

Current Rig Specs:
Motherboard: BTC B250C ver 1.2
CPU: G3900 / 6500
RAM: DDR4 2133/2400 4GB x 2
Power Supply: EVGA 750W
GPUs (all EVGA):
3070 non LHR
2x 3070 Tis
2x 3090

Post a screenshot of your worker overview screen

Here is the rig running the BTC board. If you want screenshots of anything in the bios I can plug in a monitor and provide that too. I can also ssh in and check anything.

For further context, load average is only so high just because it started up. LA is currently sitting at 0.2 which is what its usually around. Any time Ive been lucky enough to catch it crash (I check hourly to monitor this issue) I notice LA will get up to 0.8 or 1.0 before system shuts down. It’s not just a simple miner shutdowna nd reboot, the entire system will have the no connecion/offline indicator.

My assumption is that its something with the board itself (or bios settings) since if it was CPU or RAM the board would be unable to boot.

Start by flashing the latest stable image. You’re on a pretty old one.

Did you just install the 3070tis? Or did you move card positions? Or why was it not registering the memory temps until now in the graphs? Your memory clocks are pretty aggressive, have you ever gotten any gpu driver errors?

I’ve been running this system with the same risers, usb cables, power supplies, storage usb, and ethernet cable on a ASUS TUF B550M Plus for months. The miner has always frequently stopped showing memory tempatures. I havent had any gpu driver errors / failed fashes lately. The issue is not the GPUS. The focus in on the board, bios settings, and cpu/ram.

When this btc b250c board crashes it gives no errors on HiveOS, it just loses connection.
Where can I get the latest bios? The bios on this board has that old windows 98 intel board look.

Here is someone who had a similar issue. I havent been able to find any good answers online.

By latest stable image do you mean for HiveOS or the BIOS itself? Or Both? I dont think itd be the HiveOS version but I have been meaning to update it. As for the BIOS I can check and see if I can find the latest version.

Ive also found this artcile when looking for BIOS updates. Apparently these boards arent very BIOS update friendly, especially when listed as OEM. I havent plugged my board into a monitor with it running a seperate OS to see visual output when the error occurs but I believe it may be blue screening similar to this individual’s issue since the LA spikes and it loses all connection despite system still being in an ON state. I may have to look into buying a different model of this board, one with a better bios.

I am now running the latest stable HiveOS version. I have plugged in a monitor to the board itself to see what it displays when the crash occurs. I will post an image and update when that time comes. Please let me know about anything you find regarding known B250C issues / instability, BIOS issues, or how to update the bios (where a proper bios would even be located).

If issue cannot be resolved I’ll likely just return all my parts and either
A) Buy another kit with a slight different board model (pcie, usbv1.0 or usbv1.1)
B) Not bother with this and keep running two rigs instead of one with 12 gpus (not eletrically optimal)

The problem is likely due to your overclocks, if the driver is crashing and it stops showing memory temps, reduce the mem clock and reboot until it stops.

The overclocks are the same as they were before using this board.
The system, as in the whole system with board, will crash randomly anywhere from from 1 Hour to 72 Hours during mining.
I stated that the drivers nor miners are crashing, as no error show on HiveOS. I know what a driver / miner crash looks like as I’ve encountered them before. The system would still be able to connect to HiveOS but show GPUs being down and/or displaying driver issues on the worker screen.

The problem at this point seems to be the board considering I have been running without issues on a different board model. Additionally, for this B250 I have tried multiple cpus, multiple ram, two EVGA power supplies, etc.

If anyone has worked with B250 boards (Standard, M, or C with any revision) before and encountered similar issues to mine or those of the linked articles please let me know. I would like to know how common there are bios issues, defective boards, etc. as there seems to be other individuals who have had the exact same and similar issues with no resolution ever being posted.

If you know any additional moderators, admins, or larger mining operation individuals with B250 experience (or running other 12 GPU board systems) I would appreciate it if you could forward this to them to look over. The only thing I havent tried yet is if the board specifically wants a full 12 gpu load or wants gpus plugged into specific ports first before others. I dont want to risk shifting everything over to a 12 gpu system only for it to still crash. I’ve also wondered if theres a specific pcie usb ordering (top row first, or bottom row, or leftmost six vs rightmost six) as some 8 or 12 gpu boards may have this or can only handle up to 8 when nvidia but 12 when amd.

If the memory temps are randomly not showing, the driver is crashing.

Currently everything is still showing memory tempature currently except for the 3060 and 3070 which I dont think have every shown memory temaptures and only the 3070Tis stop showing temaptures sometimes (depending on which miner and version). I didnt catch your one question earlier but yes, when shifting cards between my two boards the gpu positions do change, so it may have been reading old information if the 3070 or 3060 was in the slot previously. I really think youre focusing on the wrong aspect considering this issue doesnt occur on my other board or my other two rigs.

Try setting very conservative memory clocks on all cards and see if it’s stable. 99% of instability is caused by poor/too aggressive clocks and or outdated software. (You’re screenshot shows you’re on an image from last November) before trying to troubleshoot anything always make sure you’re on the latest software.

Sorry for long response delay, since Im a new member the site limits my reply/post amount.

Do you know where I can find the latest BIOS then? I have checked online but as mentioned earlier there is no real specific area to find the BIOS for these boards. I found a bios page on both asus and biostar but both bios versions were dated older than the one in the screenshot. My HiveOS is also the most recent version.

Again on the overclocking, that would result in visible gpu/driver errors displaying on the worker screen and this issue would occur on my other boards too if that was the case. I can look into setting lower rates but I’d rather not lower my hashrates either.

I would appreciate if you could get fellow staff or other regular posters who may have additional btc b250 board experience.

Since time has passed, I can also give a bit of an update regarding the board.

It has currently been running for 16 hours straight with only the nbminer restarting itself once.
I have kept the monitor plugged in to see if there is anything on screen when / if the error ever occurs again.

Here is a list of differences which have resulted in one of the longer runs for the rig:

I have used PCIE USB ports marked 0-5 instead of 6-11. Perhaps one of the ports is faulty or the bios/kernel has a bug when the last six are in use without the first six being in use.

I have kept a monitor plugged in the entire time, making use of the boards on board integrated graphics and HDMI port. A lack of the HDMI port and integrated graphics being in use could also result in bios/kernel errors and thus crash the board.

For the CPU power cable, I have used the right side of the cable at the split rather than the left side. (The board only takes a 2x2 CPU power insert. rather than the full 4x2). While I do not think this would do anything, and I have tried multiple power supplies, I did change this and so I will note it.

I double checked and made sure 4G Encoding/Decoding was enabled along with some other graphics settings.

I will post another update after about 48-72 hours of the board running without issues. After this time, I will add GPUs one by one to the board (6-11) and see if adding to any one specific port begins to cause the error again. If the board crashes before this period I will post about the crash itself.

I have also reached out to other forums and communities; non-board proposed solutions have included using a smart switch to be able to restart the device any time remotely by switching its power off and back on. Additional solutions included recommendations for other, known to be more reliable, 8 or 12 GPU boards types. These include the standard BTC B250 with actual PCIE ports and smaller boards such as the Rebtech 8 GPU system. I have also begun to look into which of my preexisting boards, with 4G Encoding/Decoding enabled, can handle a full 8 GPU setup too.

I’m hoping to be able to solve this mystery once and for all for anyone who has run into this exact same / similar issue for BTC B250C as there have been too many internet forum posts where this goes unsolved.

Did you flash the latest stable image? Your original screenshot shows an old kernel. You’re on kernel #110 now?

I am running the latest HiveOS version. However, This issue with this board seemingly dates back for years on Windows and HiveOS mining systems though based on the previously mentioned posts.
The issue was not occuring before while running the older HiveOS version.
If the system crashes again that should confirm it is not a HiveOS version issue.

As for the BIOS I mentioned that I have tried to find more recent versions online but only find articles regarding issues updating the BIOS on BTC boards and uploads of older BIOS versions.

Before you make any comment about the 3090 giving a fan speed error I have had this happen before on specifically this card while it was in two previous rigs/boards.
There are currently no listed gpu driver errors or other errors on the dashboard.

You are still on an older kernel, #83, vs. current #110, while attempting to run all the modern HiveOS and new release miner features.

You are also on a USB drive, have updated the drivers at least once, and frankly, this process alone is known to create issues. We troubleshoot these daily in Discord. In addition, USB is also terrible when enabling logging, so don’t.

The fan error issue points to additional troubleshooting, and I’d be surprised if you ran the nvidia-smi tools to identify the many other potential issues with your rig. “GPU Driver errors” have nothing to do the the drivers.

I’d first suggest investing in an SSD. (M2SATA would be great, but I don’t recall that board supporting it). Flashing the latest stable release with Etcher, running disk-expand, updating to latest HiveOS version, enabling logs, then trouble shooting.

The board you have is known to be flaky across the wider mining community. If that is not resolved with the above, grab a TB360 Pro 2 or even an older H110 Pro and call it a day.(M2SATA in both of these). The old boards and even new old stock are now showing up at firesafe prices.

Side note: Seriously review Rebtech history before spending a dime, they have no ability to run current nVidia drivers.