Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Auto installation of AMD Drivers on HiveOS/Ubuntu

Script for the easy installation of AMD Drivers on HiveOS/Ubuntu based OS

Please note: Drivers with the 18.04 suffix require an OS upgrade
Please note: I recommend not removing drivers when upgrading.

[email protected]:~# ./
Stopping screen session 21798

Please note Drivers with the 18.04 suffix require an OS upgrade
1) 16.40-348864-ubuntu-16.04   10) 18.10-572953-ubuntu-16.04
2) 16.60-379184-ubuntu-16.04   11) 18.20-606296-ubuntu-18.04
3) 17.10-429170-ubuntu-16.04   12) 18.30-641594-ubuntu-18.04
4) 17.10-450821-ubuntu-16.04   13) 18.30-641594-ubuntu-16.04
5) 17.30-458935-ubuntu-16.04   14) 18.40-673869-ubuntu-16.04
6) 17.30-465504-ubuntu-16.04   15) 18.40-697810-ubuntu-18.04
7) 17.40-492261-ubuntu-16.04   16) 18.50-725072-ubuntu-18.04
8) 17.40-483984-ubuntu-16.04   17) Quit
9) 17.50-511655-ubuntu-16.04
Please enter your choice Drivers:

Then the program will ask if they want to remove current driver before installing new ones.

For a guided installation enter the following 3 commands


chmod +x ./


I’ve tested the script and it’s workings.
Please note it’s still in beta please report issues.
Also please provide as much detail so that way we can help.
Like what you did recently and what your running etc


Работает. СУПЕР!


получаю следующую ошибку:

[email protected]:/# wget
–2019-04-29 17:41:38--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 2902 (2.8K) [text/plain]
Saving to: ‘’ 100%[=====================================================================================================>] 2.83K --.-KB/s in 0s
2019-04-29 17:41:46 (19.9 MB/s) - ‘’ saved [2902/2902]

[email protected]:/# chmod +x ./
[email protected]:/# ./
./ line 7: syntax error near unexpected token newline' ./ line 7:

1 Like

In your home directory can you ls -la

I see it says

Saving to: ‘’

should say

Saving to: ‘’

Or you aren’t running HiveOS?
Line 7 is

systemctl stop hivex

This script is technically has the ability to be portable in any Ubuntu OS, it uses the directory structure of Hive and uses commands specific to HiveOS

Delete all the previous versions of downloads.
Great thanks ! Works like a charm.

1 Like

very nice and clean.



1 Like

Thank you!
I am going to push an update, add more options.
And it would be nice if we could add location options for download servers.

Trying to upgrade 18.10 to 18.50

18.5 wont work unless you upgrade the OS. However I did notice a driver for 18.3 and 18.4 that I think is compatible to with Ubuntu 16 which is the backbone of hive. I am going to push an update to the script that makes these options more clear. I will add the AMD driver for Ubuntu 16 that is greater than 18.1

The script is updated, download the new version and I recommend option 14) 18.40-673869-ubuntu-16.04. :wink:

Thank`s a lot !!!
Good Job to make it more clear and easy for evryone.

1 Like

hi - i just ran the script - seemed to go well, but now my miner keeps rebooting.

the error is: “GPU driver error, no temps, rebooting”

Can you provide some more details like what are you trying to mine with which miner? What cards you using?
What drivers are you trying to use?

Let me know and I am happy to see if I can help you out

1 Like


I am using claymore (latest version) to mine eth, RX570 cards, and i was updating to AMD drivers 18.40 (number 14 in the list).

i may have stuffed things up in the meantime by trying to revert to 18.10, but it looks like i ran out of free disk space while trying to do this and stopped updating and i can’t get it to restart now (that’ll teach me for booting off of a usb)…

imho For RX5xx/RX4xx you’re better off staying at 18.1 or even going a few versions lower.
I wrote this script to quickly test a lot drivers and I unfortunately didn’t see any improvements with new versions for mining (for RX5/4).
Reflash your OS and see, but also I want to ask what are you trying to accomplish with a driver update?

1 Like

Thanks for the feedback!

My goal, as always, was to experiment and try to increase my hash rate.

Reflashed and up and running again at 18.1 again, so I will stay at that given your feedback.

Thanks again for the feedback and your responses - it’s greatly appreciated!

1 Like

I upgraded to 18.40 but seems like it’s running on graphics mode not Compute. Any idea why? Hash dropped significantly


trying to upgrade to 18.50 for my new Radeon VII.
I got the error regarding hiveos update, but I cannot find how to archieve it.

I’m using Hiveos [email protected]
that should have Radeon VII support :
added OC support Nvidia GTX 1660 TI (need driver v418.43+)
added support AMD Radeon VII (VEGA’s image)

please help me :smiley:


Which Hive Image are you using?

That’s an odd one. I am going to look into that one a bit more. Google tells me nothing that relates to Ubuntu. What cards are you trying to run

I have RX580, I see on other topics people have same issue. I had a look at ROCm and tried to run the commands but had no luck. There was AMD article about as well same steps but didn`t work. Hopefully you might have some luck. Running the current version of Hive and 18.40 drivers for 16.04