Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Vega 56 and Vega 64 guide

yo :wave:

I have a Gigabyte Gaming OC Vega 64 (Samsung memory) flashed to this bios:

I can’t get it past 45.52MH/s. It’s driving me crazy. All my other Vega’s I can get past 52MH/s+

I can’t seem to improve this mem tweak, any suggestions?
GPU 1: Vega 10 XL/XT [Radeon RX Vega 56/64] pci:0000:08:00.0
Memory state: 800MHz
Memory: Samsung HBM2
Memory vendor and model 61AB1A9C
Timing 1: CL: 17 RAS: 27 RCDRD: 13 RCDWR: 8
Timing 2: RCAb (RC): 39 RCPb (RC): 39 RPAb (RP): 12 RPPb (RP): 12
Timing 3: RRDS: 4 RRDL: 5 RTP: 5
Timing 4: FAW: 13
Timing 5: CWL: 6 WTRS: 3 WTRL: 7
Timing 6: WR: 13
Timing 7: RREFD: 7
Timing 10: WRRD: 1 RDWR: 17
Timing 12: REF: 3120
Timing 13: MRD: 8 MOD: 12
Timing 14: XS: 216
Timing 16: XSMRS: 6
Timing 17: PD: 6 CKSRE: 8 CKSRX: 8
Timing 20: RFCPB: 128 STAG: 7
Timing 21: XP: 6 CPDED: 2 CKE: 6
Timing 22: RDDATA: 16 WRLAT: 4 RDLAT: 14 WRDATA: 1
Timing 23: CKESTAG: 2
RFC Timing: RFC: 208

Hello everyone and thanks for your guide vsimovic.

Just got a sapphire vega 56. It’s running at 44.22 mh/s actually. I tried pretty much every strap posted by different users and all of them just make TRM and the card restart.
Anybody has this problem or knows a solution?

Thank you and have a nice day!

Have the same thing with a Sapphire Card. NITRO+? No strap applies to it. ZERO.

Yes it’s a nitro + with hynix memory.
After some tweaking I managed to get it up to 48.8 mh/s but I still get 2-3% invalid.
If I push the memory to 960, I can’t get the RCDRD below 19. At 950, It can go down to 17. So that’s my balance for now. I just got it so I’ll try further tweaking soon.

amdmemtweak --cl 20 --ras 23 --rcdrd 17 --rcdwr 11 --rc 34 --rp 13 --rrds 3 --rrdl 4 --rtp 6 --faw 12 --cwl 7 --wtrs 4 --wtrl 4 --wr 11 --rfc 164 --REF 17000

Is the driver somehing that should be looked at?
If anyone has any idea on how to improve this setup, plz let me know. Thank you!

and it doesnt restart?

Hello everyone and thanks for your guidance, Vsimovic.

I comment on my scenario with a Vega 56 in case someone can help me.
First of all say that this is the best configuration I have achieved:

It is a Vega 56 with Samsung memory (not Vega 64 with 56 drivers). I have not made any modifications in BIOS. In this setup I have not applied any strap. As you can see, the consumption is too high and also the temperature in a regular mode of operation. I use TRM.

I have tried applying two different straps both by command and by setting them on boot as explained at Help with and saving Amdmemorytweak strap .
These would be the configurations of those straps:
amdmemtweak --i 2 --CL 20 --RAS 22 --RCDRD 12 --RCDWR 12 --RC 36 --RP 12 --RRDS 3 --RRDL 5 --RTP 5 --FAW 12 --CWL 8 - -WTRS 4 --WTRL 9 --WR 13 --REF 65000 --RFC 249
amdmemtweak --i 2 --CL 20 --RAS 26 --RCDRD 12 --RCDWR 12 --RC 38 --RP 12 --RRDS 3 --RRDL 5 --RTP 6 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 24000 --RFC 239

If I apply the strap on command, TRM reboots and the worker stops and loses connection, as some of you do. I have to reboot it manually and once restarted it works again because the straps are not applied as explained by Vsimovic in the guide.
If I set the strap on start, TRM also stops and the same thing happens a few seconds after the worker starts. Even if you reboot multiple times, this happens over and over again, so the worker is no longer operational.
I have also tried different OC settings in case they were incompatible with the new strap, without success.
This is the error I get in TRM:

Thanks you so much, anything can be of great help to me. Be happy.

As I just posted in another answer, the same thing happens to me. It’s not a Sapphire though. For now I have no solutions.

my cards are AMD and MSI. So, when doing Gigabyte, I’d start slower.
teamredminer/ETHASH_TUNING_GUIDE.txt at master · todxx/teamredminer · GitHub check this file
–RAS 26 --RCDRD 12 --RC 38 --RRDS 3 --RRDL 4 --REF 21000 start with this strap first


Hi, I would like to flash my VEGA 64 to 56. Can anyone please recommend a suitable VEGA 64 BIOS for my card ‘SAPPHIRE Radeon RX Vega 64 nitro+ 8GB HBM2 Graphics Card’ (Samsung memory).

Already tried flashing similar nitro 56 and it ruined the bios (black screen/no output); working using the second bios (via switch on card).

No it does not restart but after 1 or 2 hours I get more and more invalid share, up to 10%. I’m gonna try more setups and keep you updated.

is anyone is this problem with vega 64? if anyone can help me that cad start mine I ll pay for this!!

In windows card work perfectly but after boot in hiveos
Hiveos found vega 64 but card doesnt respond to any commands, and hive os write any other data such as temperature or consumation or fans

i tried to insert another Vbios or restart multiple times or put a card on another pcie but nothing helped

is it possible to install aother driver or does anyone have experience on what driver and what version of linux does the card work for you please?

if the card mined in any way or at least matched it , i would have handled it but here i have no idea what i can do wrong when on other pc where windows works ok(another card runs fine on hiveos).

The RCDRD value (12) you mention in your earlier post is quite low, try something like 20 and take it down slowly.

I assume you haven’t set clocks or straps yet and first want to get it running?
Please give us some more information like what brand and type vega 64, what the stock bios is and which bios you are running now.
Have you only changed the same cables to another pcie slot?
Or have you also tried to change the riser, usb cable and power cable? Maybe even change the slot into which the power cable is connected into the PSU?

yes I did not set the clock or anything else because it was useless if the card does not communicate.

it is a Sapphire radeon RX vega 64

I put the card on other risers and directly on MB and tried to change other PCIE slots
I also tried to replace the power cord

the kernel version is 5.4.80-hiveos
and the driver version is 20.40

do you think the beta version of hiveos will help?

I don’t think there is an advantage of the beta in this case; it should work on the regular version without issues so we should dig in deeper.
Is it back to the stock bios which you have hopefully backed up prior to start flashing?
Which other biosses have you tried flashing?
How did you flash them? Have you enabled both “reboot after flash” and “force flash ignore security checking” first prior to selecting a vbios?
What motherboard are you using it on?
Can you try on your Windows computer again to see if it still functions there?

I have question

no, unfortunately, I didn’t think to back up the original bios, because even after the first connection, the GPU didn’t load like the others

When I tried to download the bios for this card in Hiveos, it was successful, but still nothing changed, and even after I downloaded the bios from VGA Bios Collection: AMD RX Vega 64 8 GB | TechPowerUp

so there was still no change, then I tried again but I clicked force flash to ignore security check

then it wrote to me that it was successful and I should restart the rig but then nothing changed.

I ended up here and plugged the card into my pc with windows, where after installing the driver it popped up and worked right away.

my rig is from:
Z170A GAMING M5 (MS-7977) MSI (1.E0 05/15/2017)
4 × Intel ® Core ™ i5-6600K CPU @ 3.50GHz AES
Disk Model
SanDisk Cruzer Spark 15.4GB

Does anybody have some good straps for a crappy Gigabyte 56 with Hynix memory?

I’ve tried 4-5 straps , and I can’t get over 870MEM and 40mhs

Try something like amdmemtweak --cl 20 --ras 23 --rcdrd 20 --rcdwr 11 --rc 34 --rp 13 --rrds 3 --rrdl 4 --rtp 6 --faw 12 --cwl 7 --wtrs 4 --wtrl 4 --wr 11 --rfc 164 --REF 17000. Works on a crappy hynix 56 (not Gigabyte though)

Will try it. And oc settings?