Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Teamredminer Localhost Error

Hi All

Please help. have 3 rigs all giving me the same error and failing to launch the miner.

Failed to read teamredminer from localhost:65078

all my other rigs are running fine. I’m tearing my hair out.

any ideas how to fix this?

1 Like

Seems like TRM exited abnormally on start or possible you run other miner on port 65078 (custom miner for example)

1 Like

Thanks Halo.

But i dont have any custom miners loaded. I’ve unset the FS and re-attached it. I’ve rebooted with no flight sheet, and then loaded it.

all creates same error.

Not sure what else to do.


1 Like

Could you run Hive Shell
run miner command and attach screenshot what miner says in log

1 Like

i managed to get it running for like 20mins, then miner hangs like the above.

then agent screen brings this up again


1 Like

So …
You had hashrate on Hive’s dashboard but miner hangs after ~20 min and then you got “Failed to read …bla-bla-bla”

1 Like

correct, that seems to be the case.

and on 3 different rigs no less.

1 Like

Need to look to your rig config, TRM version and find why miner hangs.
Hive read data from miner’s API port so if miner hangs than of-course it can’t read it.

1 Like

thanks Halo

But all rigs are running same TRM Miner version .17c. All clocks are the same. Configs are the same, using the same Flightsheets.

I’m completely stumped.

What else can i do?

1 Like

so this problem arises with all the miners.

every single miner i try run on these 4 rigs or so, all hang and give some sort of api error.

ive reflashed, updated, removed, upgraded, done everything. not sure whats going on. The only common denominator that i can see is the onboard RAM gets very low when they hang,

would that be the problem?

1 Like

k, can rule out the onboard ram issue as its now happening on other rigs where they have lots of onboard ram.

gotta be someone who can help me troubleshoot this. please

how is there no one else experiencing the same problem?

@HaloGenius can you please assist? why is it that the miner keeps hanging at random, sometimes 10mins, sometimes on startup. I keep getting this cannot read from localhost.

not running other miners, rebuilt rig, other rigs with same config and flight sheets working fine.

Maybe miner not started properly … for example, can’t init GPU and restarted continuously, can’t establish a connection with pool, etc
Need look miner log to get an answer

thanks Halo

Thats the miner log, it literally just stops. I get no error notifications. the gpu’s disengage and go blank on hiveos like this

the only thing i see as a common when it does this is that the amount of Free Ram goes red. meanwhile on the other rigs they are fine. yet they all have the same amount of ram.

could you also get screenshot of agent-screen when such situation happens

Do you have 4Gb GPUs ?

yes i do.

However, all my other 4gb rigs are running fine, there are about 6 rigs that do this. the rest work just fine

As I can see you mined on Nicehash (NH) Ethash
When your worker get work from NH to mine ETC than your GPUs out GPU memory because ETC DAG size > 4Gb so as result your worker fail to mine and you get what you see
I suggest some workaround options

  1. install new Stable Image with AMD Drivers 20.30 which allow some miners (TRM, lolMiner) turn on Zombie mode (see miners manual how to do this). But you need to now that ETC on 385 epoch currently that mean hashrate will be less by 20% than on ETH.
  2. Switch from NH to ETH pool mining and sold ETH for BTC