Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Sgminer forks

A list of sgminer forks

Genesis Mining

Genesis Mining + Nicehash

zawawawa/gatelessgate (OpenCL ZEC/ETH/XMR/PASC/FTC miner)

Phi (supported PHI1612 algorithm)

djm34 (lyra2h, lyra2z)


x16r x16s (deprecated)


I can’t seem to find the phi for listed above on the options for hive

The sgminer phi is there, but it is missing from the drop down. I managed to get it to run, by renaming the gm fork to gm-backup and renaming the phi to gm. They are under /hive/sgminer

However, the miner freezes after loading the sgminer.conf I have tried just about everything, including creating my own sgminer.conf. Any help?

see error
hive/sgminer/ line 24: 8653 Segmentation fault
[ 1146.109648] sgminer[12946]: segfault at 81 ip 00007f61127ac564 sp 00007f610ec689a0 error 4 in[7f6111938000+3b33000]

for any fork of sgminer

Linux blue 4.10.17-hiveos #1 SMP Sun Dec 10 08:48:43 EET 2017 x86_64 x86_64 x86_64 GNU/Linux

any X16s update for PigeonCoin ?

While attempting to use the new X16r fork for Ravencoin, I’m getting the following error:

Fork version: 
[2018-03-30 00:17:23] Log date is now 2018-03-30                    
[2018-03-30 00:17:23] Set default algorithm to lyra2rev2 

I don’t see a way to set SGMINER_GM_URL anywhere, so I’m assuming there might be an issue of the miner fork config for the wallet. Is there something I’m missing?


Without changing anything I’m now getting a new log, which sounds like progress, but it still doesn’t appear to be working.

-- 1:sgminer-gm -- time-stamp -- Mar/30/18  1:01:39 --

and the config returns this:

Unknown miner sgminer-gm

It seems odd that since I have x16r selected as my fork, why is it showing sgminer-gm in the log?

Thanks for any help.

I am mining RVN for more than 48 hours, no prblm with RVN
here is my conf wallet, if it can help

am using RX580 8G Sapphire Pulse OC edition

@NicoRig: Thanks! That helped get me started in playing with the config more. BTW: What OC settings work best for your cards. I find it challenging to get power consumption under control and still mine at full speed on the RX 580. I have the 4gb Nitro+, the rest of my cards are Nitro+ RX 570 4gb. Right now I’ve got stock bios, power stage 4, 900mv 1200mhz core, stock memory settings. Averaging 900w from the wall. I’m waiting to see what the average hashrate is for that since it’s all over the place. Power consumption is finally decent with those settings, stock speeds at power phase 7 result in rediculous power usage. My 8 cards end up using 1600w.

how to change thread-concurrency for x16r?

@Klappy finally it is OK ? good mining ?

@NicoRig Yes, it’s mining away. Thanks again for your help. It’s really challenging to know if settings are improving output or not. The swing of hashrates are sondrastic and random that the same settings averages can change from day to day.

Great ! nice to know it is ok now

@cooler0918 Did you ever get PHI working? Now that I have mined other coins/algos with sgminer on HiveOS, this one seems to be stuck and hang when loading it. I’m using the %DWAL% and phi miner fork, as well as phi algo. Set the pool like I would any other, password c=LUX for good measure. Trimmed down extra arguments in case it was the culprit. No matter what I do it appears to get stuck at the second line, “* using Jansson 2.7”. The logs show this:

[2018-04-04 14:42:33] Log date is now 2018-04-04
[2018-04-04 14:42:33] Global quota greatest common denominator set to 1
[2018-04-04 14:42:33] Set default algorithm to phi
[2018-04-04 14:42:33] Started sgminer 5.6.1-bitbandi-3
[2018-04-04 14:42:33] * using Jansson 2.7
[2018-04-04 14:42:33] Loaded configuration file sgminer.conf

DimaFern please remove brian112358 sgminer fork and replace with his new improved fork which is the fastest AMD x16r and x16s miner for linux

Kapz786 how do i do that? i want to mine lux but it’s impossible to set up …

Как включить новый форк монера в опциях ?

Кто поможет? Как решить проблему?
Хочу майнить на алгоритме lyra2z майнер выдает строчку “GPU0: invalid nonce - HW error”

I am too having same error, did you get any solution? Thanks

Only fork from djm34 has lyra2z kernel. And it has too poor implementation.
Don’t waste your time