More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Selfupgrade failed

Selfupgrade failed

bash: line 2: selfupgrade: command not found

I’ve tried using the selfupgrade command in ssh and still get the error command not found.

How can i resolve this problem?

can you post a screenshot of the error?

what kernel/version are you on?

image

Hive OS version:
[email protected]

NVIDIA driver version:
N510.60.02

run it from the shell and post the output

I’ve tried reinstalling Hive OS, still facing the same problem.

thats odd, try running apt-get update and apt-get upgrade first

i have tried Still can’t solve the problem.

I am having the exact same issue and those screen shots you took are the same as I what I am getting. My 7 card AMD RX580 rig was trucking along nicely for about 2 years on the previous HiveOS Linux Kernel. I have been running PhoenixMiner the whole time. I decided it was about time to do an update so I could get the latest AMD drivers. I reflashed the USB drive. Things seemed fine, I noticed the OS was needing updating so I tried from the Hive browser screen and it failed. I then tried from the command line as you did. It too failed with the same error of “command not found”. Another oddity I found was that I can no longer log in via ShellInABox which is what I have been doing forever. It will not recognize my username and password, neither the deafult nor the number “1”. I can change it in the shell and it will work for a while then it will crash and reset the password to something else I don’t know.
I decided the USB I had been using was bad so I got a brand new USB and put hive on it. Same issues.
I can send OC commands and start and stop commands to the rig as well as Flight sheet info but I cannot remotely log in and I cannot selfupgrade.
Also another oddity I noticed was when my rig would crash it would reboot and try running NBMiner which I have NEVER used.
Will continue to monitor your thread.

I would have to go back and run it on Windows instead ? so sad

sounds like your rig was compromised

Do you have any other solution?

How to install this command manually ?

what kernel are you on?

I’m starting to think so. Just checked. It had been running an hour or so on PhoenixMiner, shut down and rebooted into NBMiner again.

do a fresh install, remove any 3rd party access, change ssh/system password and enable google authenticator 2fa

What’s about my problem?

What kernel are you on?

[

Hive OS version:
[email protected]

NVIDIA driver version:
N510.60.02

neither of those are the kernel, look at the bottom of your workers dashboard, next to the word kernel

1 Like

you are on the latest at least.

so just to confirm, if you do a fresh install, it wont upgrade from the base os (217-220423)?

or are you able to run selfupgrade after the fresh install and then after it upgrades it isnt able?