Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Rig crashes after Bios Flash, RX 470

Hi, after I flashed my RX 470 (MSI GAMING X, 8GB, MICRON MEM) my rig do not start mining. System recognizes both gpus, it shows temperate and energy consumption. But in less than 1 minute it goes offline. I used polaris bios editor 1 click feature. And flashed it via HiveOS (I also downloaded original Bios in HiveOS). Also overclocking my gpu is almost impossible (when it has original bios). For example when I increase MEM from 1960 to 1970, gpu can not hash. It drops to 0.00 immediately. I am sharing my settings. I flashed my rx 470 to original bios in Windows.

Do you get any errors

When i have mod Bios & setting :

try my OC for my RX 570 with the same memory.
1131 core clock
825 VDD
2100 mem clock
Aggressive undervolting switched to ON
amdtweaktool --REF 20
dont use DPM or MDPM states

I tried your settings with stock bios, nothing changed. As soon as I changed settings it goes to 0.00 then phoenixminer rebooted itself, it still did not mine (0.00 mh/s).

Unfortunately with stock bios, it dropped to 0.00 mh/s.

in hiveshell no, I did tried the gpu in windows. Maximum hash I can get was 25 with stock bios.

I also do not think it is related to power issues. I use corsair rm 750x only with 2 gpu + rest of the rig. I powered the riser with molex. I powered 1660 super with pcie. I used 2 strand each 1 for 1 gpu.

=== GPU 0, 02:00.0 Radeon RX 470 8192 MB ===
Bios: 113-V34111-F4, UUID: M613V0180815
Core: 1055 MHz 1000mV, Mem: 1960 MHz 1000mV, VDDCI: 900mV, REF: 30
PerfCtrl: manual, Load: 100%, MemLoad: 98%, Power: 73.97 W, Cap: 110 W
Core: 57°C, Fan: 67%, RPM: 2030
Core state: 4, clocks: 300 466 751 1019 1055* 1126 1169 1242
Mem state: 1, clocks: 300 1960*
PCIE Link speed: GEN2 (5.0GT/s), PCIE Link width: x1
Memory total: 8192.00 MB, used: 4518.96 MB, free: 3673.04 MB, type: Micron MT51J256M3
VDDC: 1000mV, VDDCI: 900mV

I can check your Bios Original & your Bios Mod if you share :wink:

Card is loaded ok. You have just a bit of mem tweak available there since its 98 and not 100%.
Dont use molex to power cards it will melt. If it crashes with my settings then something is of and good that you lowered them. Whats the hashes you get with the used settings .

As i see your settings are not bad. You can try to raise the core clock to 1100. Then the core voltage to 900 to reduce heat. Even 850 might be ok for your card. The you can try the vddci memory controller voltage 850 or 800. This will reduce the heat more. And then you can try with a bit higher memory clock.

Here this is my stock bios that I downloaded from HiveOS:

I can not upload directly here. Thanks.

Modded Bios :slight_smile:

Try with my setting & try other setting

Hi, many thanks for your efforts Kenshinji. I flashed the BIOS you provided. But it kind of got worse, it is mining with some OC but 1/3 of the shares it finds is invalid or it is not mining at all. I am sharing some screen shots with different OC settings. Last screenshot is from rkulov’s setting that given in 3rd comment. Also I tried your settings but it still did not mine. It starts mining with 20+ mh/s it increases but suddenly drops to zero.

I dont have same setting.

Try Core 1150 - DPM 1 - VDD 850 - MEM 2000 - MDPM 1

Ref 30


I did tried this, same happens. It starts mining but few seconds later it goes to 0.00 mh/s

Look. Try again . Get the original bios and bios mod it with one click mode. Use uber 3.1 then upload it and use my setting or start with 1100 core and 2000 memory. Dont use dpm states. Insert 800 volts core and memory. If it crashes. Increase core volts to 831 and start raising the core votlage by small and memory. First raise memory because core clock and voltage increases wattage and heat much.

Starts mining but then goes to 0.00

ok remove MDPM & DPM set 3