Increase your income with Hive. Invite your friends and earn real cryptocurrency!

"Restart miner" command does not work in ASIC HUB

Hello, I have just installed ASIC HUB software and added a couple of S19J pro miners to it. I am very interested in the Watchdog timer function but I have tested "Restart miner "command and it has not worked.
I get the message that this command is not compatible with the miner.

Any idea why this command doen´t work? This ASIC miner appears as compatible with ASIC HUB software in the web page.


Asic hub works with many firmwares, including the stock fw. Unfortunately the miner restart functionality isn’t something offered on the stock firmware, however the reboot function should work and may only take a few seconds more than a miner restart would.

:ok_hand: thanks

Thanks for your answer. You are right, Reboot command works even with stock FW.

Now I am trying to use the Hashrate watchdog to Reboot the miner if hashrate dropd below 50% of nominal value. For the moment I have not been able to get it working. Do I need to use a flight sheet in the miner if I only want to use the Hashrate watchdog to reboot it?

You should have a flight sheet applied and watchdog enabled. If needed you can post screenshots and I can tell you if I see anything out of place

Thanks! I have applied a flight sheet and it s working right now.

1 Like

do you guys know if ASIC Hub starts automatically when the machine whrere it is installed (in my case linux Hiveos) restarts after a power loss?

Yep, it should auto start, you can see if it’s running correctly by going to the ip:8800

1 Like

Hi Keaton_hiveon!

I tried to use the ASIC Hub to connect my IceRiver KS0, I saw that it is supported on the ASIC hub page but it is giving the following error when I enter the machine’s ip: Unable to probe some devices. unsupported device. Can you help me?

Make sure you have the beta version installed. This can be found in settings->software update->release channel->beta

Ok I’ll check it

It worked, thank you so much!!

I have added a new ASIC miner to Asic hUB ( Antminer K7 ) but the watchdog is not working. I fix a limit of 40TH/s ( normal hash power is 54 TH/s) and when hashpower drops from the limit, restart &reboot commands are not sent. Any idea of what is happening?
For your information, in the farm web panel, when there are problems and it shows that the ASIC miner boards are not working properly, total hashpower of the ASIC miner is not updated so may be the watchdog is getting a wrong data.

Can you post some screenshots of your watchdog config?

Please find here the screenshot

In the stats graph did the miner drop below 50TH for more than 5 minutes?

As you can see in the attached pictures, in the stats graph the miner drops below 50TH for more than 5 minutes, but, on the other hand, the number in red circle doesn´t change during that period. It seems as if that number is not up updated as it should.

What version of asic hub are you using?

Product information
Build Number

Can you please try switching to the beta, in the asic hub settings just go to software update, choose the beta release channel, then search updates and install. You may need to restart the device running asic hub as well