Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Nvidia drivers not loading on Hive OS | nvtool error | NVIDIA OC failed

I have an issue with Asus Nvidia GTX 1660 Super on ASRock B250 Pro4. I am getting the following error when connecting to shell and give the nvidia-info command:

No Nvidia GPUs found or driver not loaded

My worker does recognize the GPU: TU116 [GeForce GTX 1660 SUPER] · ASUS.

Any idea what this might be? I updated Hive OS, Nvidia drivers, reinstalled Hive OS, but no success. On the worker dashboard I get the following two errors:

nvtool error (12)

NVIDIA OC failed → No cards available for OC!

Am I missing something in the BIOS? Changed everything to gen2. The gpu is attached to the mobo directly, in the first x16 slot. Monitor is attached to the mobo hdmi port.

A screenshot from booting is attached also.

1 Like

which drivers are you using ?

I tried the default nvidia drivers that come along with hive os, version 460. Also tried 440 and 465, but no success. Which drivers would you recommend?

Have you checked cables?

I just figured out and fixed the same problem on mine after I updated the other day. I actually had to downgrade and then force upgrade the Nvidia drivers and then was able to upgrade and got it to recognize my five Nvidia GPUs on this little small eight GPU mixed rig I have of five Nvidia and three AMDs. Now it’s working flawlessly. I’m not sure what it was but I think it was an issue that GUI was disabled and you’ll find out in your worker settings. Just make sure you leave it set to Auto Detect But I went ahead and set mine to enabled and applied it and I haven’t had a problem since. I’m still not sure how it got disabled because I didn’t do it, I guess there’s a bug in the update or possibly an error in my SSD. But I reformatted reinstalled nothing worked until I downgraded HiveOS and then force reinstalled/upgraded the Nvidia drivers and then upgraded. It’s not much but I hope it helps.


i think that when you try to upgrade NVIDIA drivers , some of the tools stay not upgraded and you need to run in console - sudo apt update
sudo apt upgrade
this way it will show you if any packages are to be upgraded and for some reason they didnt automatically.

Cables changed also, same result. Changed connection to PSU also, again same result. Does not seem to be an issue with the PSU or cables.

Already did, but unfortunately with same result.

I will try this. Can you recommend on the version that you used? To downgrade to? Got back a little hope again :wink:

Unfortunately no luck. One last thing I can think of is that I am using the second port on my mother board. The first one is a PCIe x1. The second one is the first PCIe x16. Since the card is plugged directly into the mother board I had to use the PCIe x16 port. Could this be a problem?

What about bios settings? Have you set the PCIe speed to gens 2?

I had some issues like this. Updating the nvidia drivers using the HiveOS script is what fixed my issue. Open a new tab in HiveOS and run:
Will update the driver to the newest.

Yes, I did, also tried other settings in that regard.

Unfortunately also not helped.

Are you plugged into the 1660 super when you get the screenshot you posted, or are you plugged into onboard video. I am assuming because it eventually installs a generic intel driver for the display. If so, what happens when you plug your monitor direct to the 1660? If there is no video, we have to look before the OS. Here is what I would do:

  • ensure the motherboard has latest BIOS firmware version
  • do a BIOS default reset, and see if the card outputs video

If you can finally get some output from that video card, you can finally try HiveOS

You may also want to try a live Linux USB that is not HiveOS just to ensure all is ok. Try installing nvidia drivers. Does it work then?

I think you would get enough data to understand what is happening depending on what you got out of the steps above…

Let me know I am curious.

PS: Also I saw another reply that said you are plugged direct into the x16 port. That should be fine. When we use risers, we end up throttling back to 1x anyways.

You can also try changing the BIOS settings of the generation of PCIe. The big thing is getting some video output from that card…

1 Like


Thanks for your elaborate reply, much appreciated :slight_smile:

The 1660 Super was plugged into the first x16 PCIe slot when making the screenshot. My HDMI-cable for the monitor is plugged into the onboard video output. If I plug directly into the video card I do not see any image on the monitor, but also I do not see the worker come available in

The motherboard has the latest firmware (doublechecked it).

I already full resetted the BIOS a couple of times because when I turn the monitor thru onboard VGA off I am not able to boot anymore.

I do will doublecheck the URL again, you presented, to see if I may have missed something.

Will try to work with a separate Linux install, from a USB stick. I did already try NiceOS after struggling to get it to work, but there the card is not even showing up. In HiveOS I see the card recognized as TU116.

I tried the gen1, gen2 and gen3 settings in BIOS, but all with the same result. The only difference with my BIOS and the recommended settings based on the URL is I do have the internal GPU enabled (otherwise I do not see anything on the monitor) and I have CSM enabled. Same as with the previous. As soon as I disable CSM I am not getting it to boot anymore.

I was also told there might be something wrong with the GPU itself, that the drivers cannot control it due to for instance bad memory on the GPU, also leading to similar issues.

Side-note. Since the GPU is brandnew (everything is) I am reluctant to flash the vbios. Brand of the GPU is Asus TUF Gaming Graphics Card OC Edition 6GB GDDR6.


This is how the GPU is represented from the worker dashboard: TU116 [GeForce GTX 1660 SUPER] · ASUS

I did some more research into your issue, and from what I see, people with 1660 super not showing up fall into the following camps:

  • Above 4G Decoding is disabled and will not work with CSM enabled (make sure it is enabled in your BIOS)
  • Not enough PCIe lanes available to your GPU.

You are putting it into a PCIe x16 slot. Miners do not need the bandwidth of an x16 slot, and you know those PCIe risers that we plug into the motherboard to hang our vide cards somewhere else? They force any x8 or x16 lanes into x1 regardless where you plug into. Perhaps you have a BIOS setting that can force the PCIe into x8? or even x1?

If you have an M.2 slot on your MB, it also uses a PCIe lane. You can try disabling it. Just throwing out some ideas to test. Can you run the card in other slots?

I found some forum issues close to you, and if you haven’t read through, you may want to try and see if any of what they are talking about helps you. They also talk about the card being the TU116, and the motherboard is the same ASRock, but admittedly a different model:

Finally, you should be able to run a to create a nvidia bug report. Just bring up another terminal and run that. If you can upload it somewhere I can take a look at it, it may offer some help. If the nvidia tools are just not even able to see the card at all, then it won’t help…


Thanks! I have contacted the selling company and the next step is to send it back. I also am not getting output on tbe monitor and the worker does not become active when I boot with only the GPU active. I tried all your suggestions except run the nvidia bug report. If I gdt the GPU back and it should have worked, that will be my next step.
I ran from x16 but also tried x1 via riser. There is no M.2 device attached, HiveOs is being run thru a flash drive.

When I know more, I will update it here.


Hi all. For the ones facing the same problem as I did. Turned out to be a faulty GPU. I got a replacement GPU and all is well now. Because this was my first self-built rig I initially thought I did something wrong. Hopefully this will help somebody in the future to maybe search for a replacement part to see how well that is going. Replacing the GPU led to immediate success for me.
Now I can start on deining the best OC settings for my GPU.

Thanks all!

1 Like