Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Nvidia drivers not loading on Hive OS | nvtool error | NVIDIA OC failed

sir i have same issue like u 23123123123

what must i do now ??
sell the gpu ??

try to downgrade your HiveOS version.
It happened to me after I upgraded to the newer HiveOS version.
Ever since my two 3060TI wont get OC from HiveOS therefore not working properly

thank for the suggestion bro,
i already get my card for guaranted , its because Dram error

I had an AMD card that I was able to substitute for the NVIDIA. I completely removed the NVIDIA as I could not deinstall it’s drivers- same problems as above. On removing, I was able to downgrade Hiveos and then update to an oldish NVIDIA driver thro shell commands. It gave prompts saying that it was an old driver and the current driver would be uninstalled. So I did that and rebooted the rig then upgraded Hiveos. It worked. NVIDIA card mining in addition to the AMD card.

I had the same problem after a long time minig, I reflashed and worked

I am having a super similar issue, my error message is nvtool error (12). I unlike you bought 8 of these miners and have tried out about 3 of them. All give me the same “MALFUNCTION” prompt. It won’t let me upload a picture for some reason but I uploaded an image of 2 miners plugged in showing the same message to google drive (

Let me know if any of you have any solutions and if you can see the error message!


1 Like

I’m getting the the same nvtool error (12), I’ve spent around 15 hours trying to resolve this on 4 3070’s and 1 3060. Can get some cards running but not for long then they crash and get the error and (Malfunction) error.
Here is what I’ve tried so far
New hard drive, risers, power supply, 3 different motherboards
Turned “GUI on boot” in the miner settings to disabled, enabled and auto
Downgraded the Nvidia drive and updated it
Clean install’s of hive with new and old versions
Just cant figure the issue out and at a total loss.

Did you manage to fix the issue?

So after a few more hours of changing up things I downgraded Hive to [email protected] and had nvtool 1.5.7 along with driver 470.86 installed. Card did NOTcome up with the “Malfunction” and it started mining.However, after a few minutes it stopped mining and crashed, tried several more time and same thing happened.

The only thing that I had not changed through this whole issues was the breakout board on the server PSU. Removed the PSU along with the breakout board and put a 1000W ATX PSU to test it and It worked.

Tried another SSD with version [email protected] nvtool 1.7.8 and driver 520.56.06 and booted straigh up, before swopping the PSU the same SSD did not work, so not a software or driver issue in my case.

Hope this helps