Increase your income with Hive. Invite your friends and earn real cryptocurrency!

No Display on Monitor

I built a new mining rig. When I turn it on I get the bios screen, then the initial hive screen with the big blue box and the countdown timer, then I get a black screen and the monitor shuts off due to “no signal”. And there I am stuck. The monitor works fine on my other mining rig. Swapping the HDD for one with windows results in everything working just fine. While in windows I can get it to mine. I wiped the drive, installed a new image, same thing. I installed an image on a usb, same thing. This is starting to drive me crazy! Help!!


Well its a matter of hiveOS settings obsiosly. What are the cards that you mine which. Is the gui switched on?

Check the workers options where you have gui option - auto, enabled, disabled. For nvidia i think it should be enabled. For amd it should be dosabled.

GUI is on AUTO for both of my rigs. They are both using EVGA 3080 FTW3.

It sounds as though it is crashing on Hive OS boot (most likely at card driver load). Does the host say ‘hello’ to Hive at all ?

Reboot into Bios and check the following:
Primary Graphics - set to IGP , then swap monitor cable.
Disable OnBoard audio.
Enable 4G decoding.
Set PCI Link Speed to Gen 1 (to start)
Ensure Bios is set to UEFI mode
Disable secure and Fast boot

This should allow you to see what step Hive is failing at.

Sorry to necro an old thread, but having not seen any updates or real resolution on this, I’m experiencing the same issue.

Motherboard bios (Asus Z590-P) has the primary graphics set to CPU, which my I5-10600K does support, but the only way that I can use a connected monitor is by plugging it in to one of the outputs on a GPU; using the motherboard output only results in showing the blue HiveOS loading screen, then the monitor goes black with “no signal detected”.

I’ve also tried setting the Worker Options to enable as well as disable the GUI, with no change to the result. Does anyone have a real fix for this?

Oky. I found the solution.

The problem is in the new version of os. For me is working. I freshly installed version 0.6-208@210818 instead a new one and now is working.

Best regards.

Appreciate the insight, but downgrading the OS can potentially trade one issue for another.
Losing the ability to use an external monitor isn’t a deal breaker; just a “nice to have” and personally, I’d rather not lose other/more current features between those versions. Glad it’s working for you though.
I think the trick is identifying what specific configuration is different between those versions, causing the function to work as expected.

I didnt say to downgrade os.

  1. Make clean install of older version.
  2. upgrade to the latest version. Done.

Well, you were talking about going from a current version, to a previous version. Which in my case, since I’m using 0.6-210@210913, would be considered as a downgrade.
But, the semantics aside, you hadn’t mentioned anything about “upgrading” to later version after (clean) installing v208.
In the software world, it’s not unheard of that going from one version and then incrementally increasing to another can resolve some conflicts. So it might be worth a try. Thanks!
Though, I’m still curious about other resolutions on the issue and would welcome additional perspectives.

Oky you are right about that. So you can try first on a usb stick and you will se if works too… happy working.

1 Like

Which version did you fresh install ?

V. 0.6-208@210818

I am having the same issue. Just built a fresh rig, no GPUs connected. Worked great on V. 0.6-208@210818. I tried to upgrade the rig, and after booting, the same older version was showing. I did a force upgrade to 0.6-211@211121 and now the rig comes online, but doesn’t show anything on the monitor after the initial boot

Have you tried anything with the settings in the bios? Maybe bios update will help?? Which motherboard do you have?

Yes, I tried various integrated graphics options but nothing worked. It’s an MSI B450 Gaming Mobo with a Integrated Graphics Radeon CPU.

You have disabled csm and set pcie to pcie gen2, enabled 4g decoding?

But i think that is a problem in hiveos. Try to make a clean install of version V. 0.6-208@210818 and then
start hiveos in maintance mode. Then upgrade hiveos to 1 newer version, and see if works for you. If works then upgrade with 1 newer version and so on.

So upgrade from V.@210818 to V.@211104.

Same here, MSI B450 GAMING Plus MAX
HiveOS 0.6-212@211125
Disable CSM, Enabled 4G Encoding.

Having the same issue, won’t go past the blue screen. And it’s happening on the two new ones I am trying to set up. Last week done another 2 with the same MSI B550M-A PRO and had no issues. I am using a cheap gpu the gt730 but if i try with a 3060ti I don’t even get video at all.

I believe I tried all the suggestions
On my motherboard the B550M-A PRO

  • Above 4G memory /enabled
  • PCI_E2 Gen Switch/GEN2
  • UEFI set mode by default

Re-flashed 0.6-208 but stays at the blue screen.
Also set to ignore gpu but doesn’t go past the blue screen.
Also recovery don’t work.

Seems a lot of people have the same issue but no real solution.