Increase your income with Hive. Invite your friends and earn real cryptocurrency!

No Display on Monitor

Try with version V. 0.6-208@210818 and then upgrade to version V.@211104 and then report if it works. In this way ive solved a problem.

Hi Mals

I have a very similar setup to you. Did you find a solution? All looks good in the HiveOS app but no video on the rig HDMI monitor. Rig is performing well.

MB Z590-P
CPU I5-10400
Using latest Z590 BIOS
BIOS Settings:
VT-d = Disabled
IOMMU Pre-Boot = Disabled
Primary Display = CPU Graphics
PCIEx16_1 Link Speed = Gen1
Above 4G Decoding = Enabled
Launch CSM = Disabled

Hello Easy, found any solution on this? I’m having the saem issue. Thanks.


I found the following post on HiveOS team testing the TZ590. Pretty clear that the current HiveOS Linux version does not support Intel integrated CPU graphics found on Z590 motherboards. Too bad. The suggested work-around is to plug the monitor into one of the GPUs. Not great.

But I have tried to use the HiveOS web app menu item “Remote Access” at the top of the page, with either the HiveShell Start or Shellinabox menu items. With these you can at least use the “miner” command to watch the miner running from your browser on another computer. There are several other helpful commands listed in the shell when it starts up. Unfortunately, if your rig is down or locked up, these remote shell commands do not help.

Hoping that HiveOS / Linus can handle these newer motherboard chipsets soon. Z590 and TZ590 boards so far appear to be more stable.


New here, but I have a temporary solution that will help I think. So the issue I found is that my boot device go splintered, I think. Not really sure. The temporary solution I found for troubleshooting is as follows.

After initial boot, shutdown and restart.
On second boot, enter bios.
When I did this, I noticed my initial boot drive had been set to “UEFI” at the full capacity, but my OS was separate at the boot drive capacity I had made (a bit smaller than the full capacity of the SSD).
While in bios, I opened the boot menu and 2 drives were listed I clicked on the smaller of the 2 options and the machine booted and went through the boot, blue screen, and ended up in a full boot with cursor.

I’m not sure if this is a fix, but it did reenable my display within hiveos.

Hope this helps.

Jim S.

1 Like

This helped me to fix my issue with the HMTech 7" display. I have 6 AMD GPUs and by setting “GUI on boot” to “GUI disabled” in worker settings, the monitor is now displaying after shutdown and boot in 30 sec.

I have a similar set up to you. with the same mobo. hive os says my internal graphic are disabled. I’m running the latest os version. CSM is Disabled and 4G Encoding is also Enables.

Any thoughts on where I should start?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.