Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Mining rig crashing with rx5700 xt sapphire

Mining rig problem: sapphire RX5700 xt bringing the system down

Hi all! I’m struggling with my mining system, seems that there are no solutions!

I have a system composed of an Asus b250 mining expert mobo, 8GB ram, 2 psus (1300 + 1200w), and 8gpus: 2x PowerColor rx 5700 non-xt, 2x sapphire rx5700 xt, 4x MSI GeForce RTX 3060 Ti Gaming X Trio.

The miners also restart because of the sapphire GPUs, saying that both “GPU X: detected DEAD (XX:XX.X), will execute restart script”. I have noticed also in the miner that before doing this, the hashrate drops to zero but, more interestingly, the VDDC goes downhill to around 65mv.

I already tried:

  • the 3 sided-molex plugged-in
  • Removing the OC and run stock
  • different bios
  • different cables
  • different hiveOS (tried beta and stable)
  • different slots on the psu
  • put the AMD’s first and Nvidia’s second (and vice-versa), put the XT first, the non xt first and also XT → non xt → xt → non xt
  • different risers
  • different miners
  • Gpus placed sequentially and spaced (4 GPUs on first 4 positions of A lane and 4 GPUs on 4 first positions of B lane)

Any other ideas?

Thanks in advance!


I have the same problem/behaviour with my Sapphire Pulse too. Is your Pulse models ?

I’m too use a B250 mobo with grosso-modo the same setup/config than you.

Thank you

Exactly, they are the pulse! Did you found a solution?

Not at this moment.
I also have Sapphire RX5700XT Nitro+ that operate without any problem.This seem related to Pulse model only.
I mod the bios related to this post :

From what I can see, it’s really related to OC settings. I tried many setups. All seem reasonable settings. With some I have reboot each hours, with some I have 1 reboot per day. With others, I have random reboots per week.
So I guess this is really an OC thing.
At the moment I use :
1280 750/800/1320 910
Seem stable with good hashrate : 55.9MH for around 90W (120W per the wall I think)

Waiting for your advice too :wink:

Hi guys I would like to help you in some way!
My question: What software are you using with?
If you are using Teamredminer from v0.8.0 there have been some significant changes to all overclocking and miscellaneous settings.
If you are interested and we are talking about the TRM software v.0.8.0 or later I could help you with this magnificent overclock setting! With only 78 watts you can reach 55.10 MH / s.
Hope it can help you.
Hi guys.

1 Like

Thank you. Yes I use TRM 0.8.1.

From what I see and imagine, while review you settings, the GPU Dead is related to MVDD. Going too low with this setting may be the problem.

I’ll give a try to you settings next days and report.

But you see that I have modified the bios as indicated by the migration guide from trm v0.7.22 to v 0.8.0.
So you see then in the miner settings in the additional configuration arguments section you have to enter this string here:
–eth_config = B608
If it helps you I made a post a few days ago. You can find it at this link on hive.os

Then if you want more help send me your bios and I’ll fix it as I did mine without any problems.
In case you contact me if you are having difficulty.


Thank you. I too mod my Bios.

Anyway, your sapphire are Nitro, not Pulse model. And as we state before, the problem happen only on Pulse model, not Nitro or Nitro+ nor Nitro+ SE.

Sadly, the problem occurred also with old versions of TRM.

I’ll read your post and look what I could do. From where came this guide ?
Also, from IgorLab, what did you done for memory timing ? Apple Strap or Copy/paste from values ?

thank you :wink:

The guide can be found on GitHub where they release the software.
In the links below you can see the entire migration guide with all the explanations.
Enjoy the reading

Thank you.
Here is my current settings :
GPU2 and GPU3 are Sapphire Pulse
GPU1 is Sapphire Nitro+SE

With the new setting you sacrifice 1.1 / 2 mh / s to gpu but you save 58 watts in the rig … And there are not a few you see.
The new version of TRM v 0.8.0 low overclock as you have seen in my settings but remaining very high in terms of MH / s so an excellent compromise if I can do 55.1 MH / s with 78watt.
Imagine 6 gpu with 78 watts total consumption 468watt … Maximum efficiency mh / s vs watt.

Still no luck with the previous OC settings.
1 or 2 days and it reboot…
Need to dig in a little more…

Thnaks for the tip, it is in my queue of settings to be tested :slight_smile: Just one question: why do you specify the eth_config to be the B608? I thought this was a “random” number as I get different ones (eg. B564, B623, B576). Does this termination matters or only being Bxxx is enough?

I tried 1350 / 750 / 800 /1320 / 910 and got an uptime of 1 day 12 hours, which for me is a big improvement. I’ll try your settings (1280 750/800/1320 910 ) to see if improves a bit. If not, then I’ll give a shot at Claudio_Fresta settings :slight_smile:

Bxxx is not a random number but a TRM setting. It tell TRM how to deal with your card.

I will keep an eye on them! Maybe they are the key to this :smiley: I’ll report back soon some results regarding this :slight_smile: did you tried the B608 value?

Guys I answer everyone like that with facts and pictures.
Hi everyone.

Guys to get these results you have to modify your current GPU bios!
Open the bios with Igorlab’s Red Bios Editor go to VRAM Timings click on 1550 or 1500 change both bios and
for samsung than for micron.
A new page will open, you have to double the value you find in the DRAMTiming13 box in my case 2945
I double it x2 and it becomes 5890 and hit ok.
At this point, delete all straps strings greater than 1500 or 1550 and copy the strap of 1550 or 1500 in
1750-1800-1875-2000 MHz etc. etc. in both Memory Types and save the new bios created.
At this point you just have to flash the new bios.
Fix the overclocks shown above in Hive os and that’s it
Maximum efficiency MH / s Vs Watt.
Good job everyone.
red bios editor

Hi, I got my power down a little with your settings, but can’t use B608, not enough memory? I got 8gb 5700,s and one XT, but they use B576. Any idea?


The last two cards are 580 8gbs.

When you specify a higher value than supported, your GPU automatically thanks the highest value supported. From the images, I don’t see any XT… which #gpu it is?