Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Issue H510 Pro BTX W/3070x3 pcs

Hello everyone, I’m new into the community and also mining. Yesterday after finishing my rig with this hardware: MB ASROCK H510 PRO BTC+ / ASUS ROG STRIX RTX3070 O8G Gaming x 3 pcs; I created my account here (after seeing some videos), and I started mining. The problem I have is that I can only mine 1 GPU, the other 2 seems to detect them but not at all and are not working. Any idea what could it be?

Here you have a picture of the issue:

since you started just now , i guess you have driver 460.39, you might need to update that to 465 i think. and dude use absolute core clocks for OCs.

Thanks for your answer Rkulov, I’ve just updated the driver to the lastest version and still the same issue:

Have you switched (tested) GPUs where GPU 0 is connected to verify that they all work in the slot?

Yeap, all of them work fine

This is all I have done:
-Updated the nvidia driver to version 465.31.
-Swith the vga’s to see if each one works individually, and indeed they all work.
-Tested alternating on the different PCIE ports.
-I tried connecting one via USB and one riser.
-Switch the SSD with HiveOS from the SATA port to a USB port using an adapter.
-Revised the BIOS settings

I’ve run out of ideas, and the last one I have left is to try mining on Windows, maybe it’s a question of compatibility with Linux, being a new motherboard.

I’m not that familar with ASROCK H510 PRO BTC+. But it looks like you’re able to put the 3 GPUs directly on the board without riser. Also, on motherboard after a brief look at the manual, there are indicator LED for the GPU’s, are they all good? Does manual say anything about the order or where you put GPUs first? In BIOS what generation do you have PCIE slots set to? Do you know if the other GPU’s are getting power?

When the mother boots, the first thing it shows is an image of the MB with the ports connected in green (working fine), or red (not working), in my case they are all 3 in green, so the mother is detecting them. There is no specific order, in fact if I place the 3 vga in any of the 6 ports, it is always only one that works, and the other two don’t. The BIOS has the PICE versions set in AUTO.

I just made another test, connecting a second PSU to feed another of the 3070 separately, and the result is the same, the mother detects it, but apparently HiveOS is not detecting it, because it detects it, as you can see in the image that it does detect it, but not completely.

I am more and more convinced that it must be a system issue.

They don’t seem to be getting any power. Do you have power cables going into any of 4 pin connectors of image of the MOB below?

I was able to duplicate what seems to be going on for you. The image below I left everything plugged in on the image below besides the power at “top” of the GPU which for mine it requires 8. I’m thinking it’s a power issue.

The four 4-pin connectors are connected, and in turn each of the three 3070 has its 8+8 pins connected. The power should not be a problem, since I am using a seasonic 1000W.

4G encoding switched to ON in bios ? PCIE bus speed to gen2?

Thanks for your support rkulov and hivekal, but the issue was the OS, since I’ve installed windows last night and everything is running well. In a few weeks I will check if any asrock update is released to try to upgrade to HiveOs, as I find it very friendly and easy to use, except for the punctual problem I had.

1 Like

Hello!!! How did you manage to connect more than One gpu i can only connect One on Windows…

which driver are you using in windows?

Latest One drivers and a Celeron 5905 Will i have limitation on PCI express with all gen One selected

Well in hive os you used older driver. This might be your answer

What drivers version you recomend?

Done, same resuts