Increase your income with Hive. Invite your friends and earn real cryptocurrency!

IceRiver ks0 - lost connection with Asic-Hub after 1 day


I have a Iceriver ks0 miner, and I try to use ASIC-HUB on HiveOS.
I use of ASIC-HUB (i guess lastest version on linux),
and after 1 day uptime, my miner goes offline on my Hiveos dashboard, but my miner is still online…

this is what i see asic-hub logs: (I repeat… this error occurs after 1 day uptime)
11:53AM WRN device (kakukk) is still offline error=“iceriver: failed to connect to API - Post “”: dial tcp connect: connection refused” ip= kind=ICERIVER mac=yyyyyyyy name=kakukk rig_id=xxxxx tag=monitor type=“IceRiver ks0”

I can connect to miner dashboard ( and i can login to userpanel.

If I restarted the Asic-hub nothing changed… but if I restart my miner, the asic-hub goes online for ~1 day… and this problem repeating.

Any idea, how to fix this?

Does it go offline at 24hr uptime on the dot?
Do you have any other asics in asic hub? If so, do they also go offline?

When accessing the dashboard of the miner when asic shows offline, does the miner respond to changes? (Fan/wallet/pool)

Littlebit more than 24 hour uptime… around 32 hour.
I dont have any other asics… only this.

Yes. Miner respond any changes, and still mining, just asic-hub shows offline…

Have you rebooted the linux system since updating asic hub?

Yes, of course!

After 33 hours uptime, the issue is come back.

Hi, Did you manage to solve the problem? Unfortunately, this is also the case for me. The http process stops after 24 hours on 5 different machines.

what version of asic hub are you using?

Hi, It has the latest (1025976424) stable version, I recently updated it, but before that it had (1015471286). Unfortunately, he does it with both. Here is a log detail that will be familiar:

{“level”:“warn”,“tag”:“monitor”,“rig_id”:“xxxxxxxxx”,“error”:“iceriver: failed to connect to API - Post “ /userpanel”: dial tcp connect: no route to host”,“ip”:“”,“mac”:“xxxxxx”,“rig_id”:“xxxxxx”,“name” :“IceRiver_KS0_4”,“kind”:“ICERIVER”,“type”:“IceRiver generic”,“time”:“2023-10-10T23:42:59+02:00”,“message”:“device 192.168. 0.103 (IceRiver_KS0_4) is still offline”}

It produces it in 4 different hardware environments, ks0 is hacked, I can see it on ssh, but the log doesn’t write anything, which seems to drop the http process. I don’t know why it can and how else it can exist with the ks0 - hiveonhub connection. After the ks0 restart, it works again and can be seen by the hub. The hub is installed on rapsberry and rig alongside hiveos.


You can try a few things, id recommend try the testing branch version, and increase some of the time values found in the settings a bit to see if it makes a difference.

Use latest Beta or Test version… and of course upgrade the latest ks0 firmware.
At the moment my ks0 miner and the latest testing version asichub working great more than 6 days… :slight_smile:

1 Like

Thank you for your answers.

The latest test version number is: 1025977320 / 04-Oct-2023
The beta version is 1007121947 / 16-Sep-2023
It now has this: 1025976424 / 04-Oct-2023
I think the test version is according to the latest number, do you recommend this?

Also, which setting value should I change and how much?
WriteTimeout, ReadTimeout, ScanInterval, MaxIdleConnsPerHost
Or for monitoring:
MaxGroupSize, StatsCollectInterval, StatsSendInterval, ProbeTimeout, ConnectTimeout, IgnoreMirrorsList, HubHeartbeatInterval

Thank you in advance for your help, it will be useful for others if you manage to solve it.

try increasing all the interval values. also, are you on the latest firmware?

I’m running 3 ks0 and 1 ks1 with testing version and latest device firmwares (all overclocked now as well) and haven’t had any issues at all with UI. (HUB VERSION)
1597994_ks0140miner (FIRMWARE).
It has the latest firmware with 140 oc. Unfortunately, I have not been successful so far, one of the systems froze this morning in addition to the above. I’ll try changing the values today to see if that helps. If you see a contradiction in the above, please let me know. Thanks.

Unfortunately, the error was not resolved. In the meantime, I looked up a few things. Hiveonhub also pumps the appweb process to ks0 with status questions and fills the machine’s memory. approx. After 1 day of running, the memory runs out and the OOM Killer kills the KS0 AppWeb application and the connection with the hiveonhub is lost. I don’t know what solution exists for this on the hiveonhub site, but I suspect that the ks0’s firmware is faulty, even though it has the latest firmware. Just in case, I wrote a scrypt that monitors the memory and restarts the appweb process when it runs out, and hiveonhub experiences only a minimal 1-second outage per day.

Can you share your script? I get the same thing…

After 8 days uptime, my issue is back.
Temperature shows wrong data…

Can U share tutorial with your script? :slight_smile:

I have a horribly bad linux system on ks0. I am constantly developing and perfecting my script.

The error: after about 1 day, appweb eats up the 160mb of free memory, leaving about 3mb, and then it crashes. A temperature value of 0 indicates that the appweb is already dying and slowly dropping values. Then only the reboot will solve things.

The script I wrote took a lot of time and is still under continuous testing. How it currently works:

  • detect the appweb application
  • monitors your run every minute, starts it if you are not running
  • monitors free memory up to the limit of 30mb
    • if the limit is reached, the appweb will be restarted, we have won a day again
    • if you try to reboot 3 times in 10 minutes but do not gain a relevant amount of memory, issue the reboot command to the entire machine.
    • logs the actions in its own logfile, with a time stamp, for 6 days, and then overwrites the oldest one so as not to clutter up the machine.
  • linux is out of date, so it can’t remember the time, so the log entries are worthless, I made a script for this as well, which takes the current time on ntp, sets it when the system starts, and then checks and corrects the slips every hour.

I would like to share it only when the machine is proven to be stable, even with the v1 version I run flawlessly at 1d20h, the v2 version at 12h.
Of course, I have already tested the errors and it worked well, I’m paying attention and waiting.

Okay, I wait :slight_smile:
Btw, how to restart appweb process?
I can’t login ssh to my ks0… i dont know why… but invalid password everytime… :frowning: