Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Http:// is not working and cannot change rig.conf to other working URLs

net-test results:

Checking connection to Hive servers:
nslookup                                        [OK]
ping                                            [OK]
curl                                     [FAIL]
HTTP connection failed. Please check Firewall rules or connection setup.
curl                                    [FAIL]
HTTPS (SSL) connection failed. Please check Firewall rules or connection setup.
curl                               [FAIL]
HTTPS (SSL) on port 8443 connection failed. Please check Firewall rules or connection setup.
curl                              [FAIL]
HTTPS (SSL) connection on port 41282 failed. Please check Firewall rules or connection setup.
nslookup                                      [OK]
ping                                          [OK]
curl                                   [OK]
curl                                  [OK]
nslookup                                     [OK]
ping                                         [OK]
curl                                  [OK]
curl                                 [OK]

Since the api is not working and paris is, I would like to change that url in rig.conf. However, it gets reverted immediately. Until the problems with are resolved, how can I switch to paris or other working servers?

My rigs are mining but show offline due to this. api server needs to be fixed.

I am having this problem after reinstalling the hive them on a memory card (it was working normally until this morning) is now giving me this message ethminer exited waiting to cool down a bit can someone please help me

I finally resolved communication issues with It was the IPv6 in /etc/hosts because of which the connection to was not happening.

I commented out all the IPv6 stuff and disabled IPv6 on the machine using following commands:

sysctl -w net.ipv6.conf.all.disable_ipv6=1
sysctl -w net.ipv6.conf.default.disable_ipv6=1

Hi bro, I have the same problem just right now, and my rig can’t connect to api at all, even do not open on my laptop!! where should I write and enter those commands? I will thank u if u answer me as soon as possible.

Where did you copy those command lines?

I’m dying here in 2021 trying to find a fix for this. Where do I enter those command lines? It looks like my machine failed the 114 DNS ping. Everything else was fine.

1 Like

To anyone having this issue go to network folder on the usb and in 20network file remove the commenting #'s where it says disable ipv6. This helped my problem.

Same & more here…

Static IP & Disabled ip6, still no luck.
Any recommendation and/or ideas?

Also have the exact issue :confused: any ideas?

I bought the wifi extender (tp-link model number TL-WA850RE) and connected an ethernet cable to it. This solved my issues completely with firewall, couldn’t connect to api, curl issues and more. tp link TL-WA850RE

Была ошибка Error connecting to Hive server
Помогла замена api на другой (

So, I have been having the same issue but couldn’t find how to change my url to PING off the lowest from the list. And I finally figured it out and hope this helps (perhaps bit late for you but maybe others that will be reading this in the future).

remote access ==> Hive Shell Start
from the menu do a net-test and find the lowest PING (for me I wanted to change from to (lowest ping number)
“firstrun -f” (this will force rig set up) and will prompt if I want to continue with current URL or enter a new one (which for me will be then follow the prompt to enter rig id, pw… so on… you are done.

just to make sure you’ve made the changes, can go back and type in command “net-test” to see the URL you wanted is noted as “CURRENT”

I have same issues until i figure it out that my rig is connected through some old bad switch which caused latency and pocket loss. Try to connect rig directly to the router.

Did firstrun also reset settings?