Increase your income with Hive. Invite your friends and earn real cryptocurrency!

HIVE OS not flashing GPU's or downloading VBIOS

So I recently have been running into an issue were I attempt to flash a card on my rig and ultimately nothing happens. It shows the command goes through and shows the flash is in process but then it just sits there like the for 5-10 minuets. After that period of time and some page refreshing the in process message disappears. I’m also looking at the recent commands list and notice that it does not post the VBIOS flash command or show any success or failed messages. In addition to this I can’t download any VBIOS for any of my cards.

I’ve tried a few things such as shutdowns, reboots, miner stops but not having any success. Looking for insight on what might be the issue. Any help much appreciated.

when this has happen to me, i have had wrong vbios that i have tried to flash, i for sure the right vbios i have forced flash. No bricked cards yet… and download… sometimes it just dont work… expecially when i have had card with vbios allready flashed to it… dunno if anyway same as your issue, just my experiences

So I know its not the wrong VBIOS im trying to flash since my cards are all 5700 evokes and they have a modded bios on them already, i just did some further changes to the memory timings to that same bios and saved it as a new one. I select the option to force flash also. I’ll keep trying but I dont want to brick a card. Im afraid that if its stuck saying the flash is in process that if i reboot it will screw something up

is there dual bios on those cards… i dont know that model

Nope no dual bios option. So I did look deeper and found under the activity tab for the worker that there is a command sent for the bios flash but that command does not show up in the history at the top of the page. I did try it again on a different card and same issue. Its like it just times out and nothing changes. no reboot, no hash changes…nothing

Well… cant say whats up there but when i have tried to download bios in hive for card that have flashed allready, i wont work. and i have aborted flash like 20 times when stuck on message “in progress” and never any issue after, just the bios that were on the card is still the same. and all your sympthoms like no messages about failed or fals succes missing, they are familiar when have tried to flash with wrong vbios… that is strange that it dont flash when forced… so are cards still working anyway, hashing normally?

Okay I found a work around. I got it to flash when i went to the Overclocking tab in the worker. I was doing it on the Cards tab before. But yes everything was normal after it “timed out” and hashed normally

1 Like

so u think that flashing from overclocking tab made the difference? did u had miner stopped or maintance mode? just asking for to get info for future if needed. great that u got it solved anyways :+1:

Thats the only thing I did differently this time. No miner stop or maintenance mode.

1 Like

I have the same issue on my AMD rig.
I am trying to flash from overclock tab, and it sends the command and shows it “loading”, but then it just goes away without doing anything.

I can’t download or flash any of my 6 cards. I have tried everything i can think of…

Any fix for this?

Try both the overclocking tab and the “cards” tab on the previous page where it shows the workers for that farm. Do it one at a time to see.

normally when it goes like this, the reason is wrong vbios that is tried to flash.

Im 100% sure that this bios works, since it worked on another rigg.

Thanks for trying, cards tab did not work either. Must be something wrong with this hiveos setup, since it worked from my other rig.

hello, I also have the same problem, do you save it?

Same here, downloading a vbios will stuck at loading command, but after refresh it’ll be gone with no download link to the vbios file. It used to be working before I updated the hiveos version

Any solution for this problem?


I am unable to download bios. Error message “adapter not found”. (Mining stable)
OS Version [email protected] Before upgrade I was able to download and re-flash.

Please let me know if there is any solution.

The same issue here: AMD VBIOS saving failed => AMDVBFLASH version 4.71, Copyright © 2020 Advanced Micro Devices, Inc.

Adapter not found


If you guys have RX 6600 or 6600Xt cards connected, please disconnect and then download.

1 Like

I have RX 6600. When I disconnect the card, there is no option to download BIOS (please see the screenshot). And when I turn of the rig, it is trying to download but it ends with the same error