Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Help with and saving Amdmemorytweak strap


I have a good strap for my Vega 64 that is working however every time I reboot I have to reapply it.

How can I save it is automatically loaded on reboot?

It has been mentioned to store it in . Can someone please point me to walkthrough on how to do this correctly in Hiveos? I am a bit of a Linux noob as well.



You need to login to your hive using Shell In A Box (at the top, under remote access).
Login will likely be User: user , Pass: 1

Once you login you will be at a prompt. FIRST, change your remote login password:
hive-passwd PASSWORD

Next, lets edit those tables:

install nano for editing:
sudo apt install nano


This will open a new window basically showing the contents of the file. Using your keyboard arrows go to the bottom and type your straps. You can copy and paste, but you have to right click and “paste from browser”

So it should look something like this:

Now save by hitting Ctrl + O (hold control, then hit the letter o)
type Y to overwrite the existing file

Now exit nano by hitting Ctrl + X

You are now back at the terminal. Set Hive so that it start the GUI on boot.
In the terminal type “sudo reboot” and the system will reboot.

I hope this helps!!!


Wow, thank you so much! This is super helpful and exactly what I needed. I couldn’t find this information anywhere in the forum and when I Googled around it wasn’t clear exactly what I needed to do.

Thanks again.

Thy m8, i was looking for it too.
Now restarting and lets see…

How do you set Hive to start GUI on boot ?

Hey SybrBlue,

Many many thanks for the tutorial, - extremely helpful! I am running into a problem though, after setting the Hive into “GUI enable on boot”, my Hive OS does not boot anymore… It stops at “a start job is running for net preconfig” and runs indefinitely. I understand it will not apply the straps without “GUI enable on boot”. Do you happen to know what might be the problem? Or is there anyway other way without enabling the GUI?

Thanks once again.

Kind regards,

I have a stupid problem. I can’t login with user and password 1. Where do you define the username or password?

You’ll need to be at the physical unit, but the command is: hive-passwd PASSWORD

replace PASSWORD with what you want to the password to be. the user will remain “user”

I don’t know what the problem is, and I have not found a way to automatically apply the straps. you could look into using cron to run a script on boot…

Sorry I can’t help.

Click the wrench and screwdriver, then turn it on.


Is it possible to run the amdmemtweak command as a cron job?

I followed this instruction but for some reason the strips won’t load at start up. Strips stored to the properly but didn’t run automatically at start. Using Phoenix Miner with a mixed cards rig. Do you have any suggestions?

You need to use Teamredminer. AMD only.

Thanks for the advise. I will check this.

i have the same problem now, just changed my miner from a USB stick to a SSD and i can not get the straps to load on startup…

I reworked my Vega rig and now straps are not loading using I am starting to believe there is a bug.

I noticed too unlike last time none of the commented out code exists at the top either. Something is up!

that’s not true, straps have nothing to do with the miner or with your rig being amd only; i have a mixed rig too and used different miners before; i ended up with teamredminer for my amd cards and trex for my nvidia cards, but it worked fine with phoenix too; as long as you indicate the strap for the correct amd card number you’ll be fine

I seem to have a sort like issue; I also expanded my Vega rig from 8 Vega’s to 10 and the straps aren’t loading anymore. I’ve double checked the old and new straps in the and they all have the correct gpu number and the straps work fine if I load them from console manually.
To get over the limit of 8 simultaneous AMD Vega cards I had to disable CSM in Boot section of Bios.
[EDIT] I had also placed my rig in maintenance mode so it wouldn’t start the miner after reboot so I could add the OC’s and straps for the new cards; then I’ve disabled maintenance mode and rebooted [/EDIT]
Did you have to do the same? I can’t think of anything else that I’ve changed.
I’ve tried downgrading hiveos to an earlier version but that didn’t change it. Back to the latest version now without auto straps. When the rig auto reboots for some reason, the straps are gone and I loose a lot of hashrate :cry:
Maybe next week I’ll start with a fresh hiveos install if no solution have turned up.

I figured out the issue. This is the reason why others may be having trouble getting this straps to load on startup.

Solution: before typing nano type cd /home/user

This is where the file is stored. You used to be able to do it as soon as you log in via shell but I guess not anymore.


I am getting the error, that this directory did not exist.