Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Guide to update amd drivers

Hey guys,

Is there a guide for the driver update? The script wont work for me for any reason :frowning:

What are you waiting from drivers update?

I tried 20.xx version and had same hashrateat less mhz,so I could decrease mvolt and save some watts…or increase hashrate at same mhz…but i cant verify in hiveos because i cant update the driver. My card is newer than the 19.30 driver…thats weird…

AMD driver package and AMD drivers builtin in Hive OS not the same things
Builtins AMD driver is mix of 3 things

  • AMD linux kernel module (latest from AMD repository)
  • AMD OpenCL libs (for best hashrate)
  • AMD GPU firmware (from latest AMD drivers package)

So why do i then have better results with official newesr amd driver and how can i reach same results in hiveos…must be an optimization to the driver after latest firmware release of my 5700 card i assume…

I finally got it…updated to 20.20 and got 0.5 mhash per card at same watts.

1 Like

Can you tell us how did you manage to update to 20.20 ?


sure…give me some days to write a guide…maybe i make a new topic

guide to update amd drivers to 20.20 which is the latest driver supported by phoenixminer. you can update to 20.30 or 20.40 if you have another miner that supports a newer driver.

boot to maintenance mode with loading drivers
open remote access
cd …
cd hive-drivers-pack
tar -Jxvf amdgpu-pro-20.20-1089974-ubuntu-18.04.tar.xz
cd amdgpu-pro-20.20-1089974-ubuntu-18.04
after uninstall check dkms status:

dkms status

-> if you have Error, use command:

for i in /var/lib/dkms//[^k]/source; do [ -e “$i” ] || echo “$i”;done

copy the output line directory and remove those directory (or directories if more than one is listed in outut)

rm -r “directory”


check “dkms status”
should be without errors and without amd driver now

cd …
cd hive-drivers-pack
cd amdgpu-pro-20.20-1089974-ubuntu-18.04
./amdgpu-pro-install -y --opencl=pal --headless

reboot without maintenance mode - done


Great ! Thanks!

When I run “dkms status”, I get the error “Error! Could not locate dkms.conf file.”
And when I browse
I do see 5.6/ 5.6.5/ kernel-5.0.21-201105-hiveos-x86_64@ kernel-5.0.21-hiveos-x86_64@ kernel-5.4.67-hiveos-beta-x86_64@ kernel-5.6.0-hiveos-beta±x86_64@
And withing each directory, I have something like
5.6.0-hiveos-beta+/ source@

Any idea how I can move forward?

Thank you in advance,

it´s one post above. you need to delete the directories that are shown after typing the command. should be clear

Thank you. I saw that, but when I do “for i in /var/lib/dkms//[^k]/source; do [ -e “$i” ] || echo “$i”;done”
I get :
And I am sorry, but I do not know what to do from here…

There’s a typo in the command it should be:

for i in /var/lib/dkms/*/[^k]*/source; do [ -e “$i” ] || echo “$i”;done

damn…didnt see that…copy pasted it into this forum…sorry for that

i am getting an error where it won’t let me remove the dkms directories i have installed. I have three and I assume I should leave the amd one alone. Please some help would be great

Good stuff! Thanks for taking the time to post this.

hello, thanks for your guide.

i tried to do all steps, had to change “amdgpu-uninstall” command to “amdgpu-pro-uninstall”
and install gets stucked on “Building initial module for 5.4.80-hiveos” and then error.

after restart it says A: 20.40 but can I trust this? my 6900xt still does not be recognized


any help?

just a quick self reply, I made a new boot hdd with fresh install and the problem continued, even if the new amd drivers 20.40 are already in the latest build.

then I made a clean BETA install, and its working…


so… users that have this problem, use the BETA version for now…

did you tried install 20.50??? i am stuck at “WARNING: amdgpu dkms failed for running kernel”

no, i did not. on Hive GPU Drivers Collection only 20.40

regarding dkms error, see the procedure CryptoMining talked about. I tried all the process but always got an error on kernel.