Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GTX 1660 Super showing as TU116

I just finished my first rig with ASRock X370 Pro4 Motherboard, Ryzen 3 1200, 4GB RAM and 6x GeForce GTX 1660 SUPER.

So far so good.

Unfortunately my rig mines only with 4 GPUs, when I try to use the fifth one it only displays as TU116 [GeForce GTX 1660 SUPER] with the error message “NVIDIA OC failed”

I tried everything mentioned in this forum

Newest Kernel
Newest HiveOS
Newest Nvidia driver
Newest BIOS
Enable 4G above
Changed Risers and Cables …

Nothing worked.

I hope here is a Supercrack who finds a solution.
Seems to be a problem which a lot of users have to fight with.

Thanks in advance for the help!

Hive throws this message
20210527 16:54:02 ERROR: Can’t start miner, can’t initialize CUDA engine, cuda exception: CUDA_ERROR_INVALID_DEVICE. Is NVIDIA driver installed?
20210527 16:54:03 T-Rex finished.

And nvidia-info shows this strange behaviour

i am facing the same with an AsRock Z490 on HiveOS4 rtx 3070 in rig, only the 1st one mine with no problems, the other ones shows GA104 [GeForce RTX 3070], it lists like:
0- Geforce RTX 3070
1- GA104 [GeForce RTX 3070]
2- GA104 [GeForce RTX 3070]
3- GA104 [GeForce RTX 3070]

the gpu 0 is able to mine normally, all others dont, updated bios of mobo, updated HiveOS, updated drivers, changed bios settings (PCIE gen1 or 2 instead of auto, 4g decoding enabled and tried also disabled and many other bios settings), changed risers, slots, PSU.

the same setup with another mobo+proc works normally, so i got other video cards from the other rig (2 1660S) and got the same behavior as you:
Hive lists this way:
GeForce GTX 1660 SUPER
TU116 [GeForce GTX 1660 SUPER]

and of course the second one was not able to mine.

so it seems i resolved this ( i did it some hours ago and it is mining until now) with:
went to motherboard bios setting and DISABLED the 4g decoding and changed all PCIE settings to Gen2, after this it recognized the second 1660super and tomorrow i will get back all the 4x RTX 3070

try this and let us know

Thank you for your in depth response.

I tried as well Gen2 and 4g disabled.
I can mine with 4 cards, but the fifth isn’t recognized.

Today I will try to change the PSU for the mobo, as I was running it with a Pico.
So perhaps …

Are you mining with only two 1660 Super or are they running along your 3070?
So what is the total count of cards your running on the AsRock mobo?

Thanks in advance

So now I have changed PSU, but to no avail.

I changed the risers and cards and it has nothing to do with those.
So I assume it’s the motherboard.

The card which is failing is in the fifth or the sixth PCIE-Port counted from the CPU.
ASRock naming is PCIE5 and PCI6.

I noticed something else.
The card that’s failing is the one, that is numbered just one count before the next one.
See screenshot.
Is the address-space the culprit?
Can I change that in BIOS?

I saw a YouTube video today and I cannot think for the life of me who it was - he was reviewing ‘1060’, ‘3060’ etc gpu and they had the same code as the one you’re getting. Not sure if it could be related

I am shure that the cards are no fake, they mine with over 31 Mhash/sec.

I think the Motherboard is the problem.

I read that perhaps PCIE5 and PCIE6 always run at Gen3 or Gen4.
It’s not possible to set them to Gen1 or Gen2 in the BIOS.

Anyone here who can check that?

@vibe18 are your cards running?
Are you able to set the speed to Gen2 for each PCIE-slot separetely?

this is not related to fake cards but to motherboard settings, I got the RTX3070 in other motherboard that runs AMD processor and it worked, in this Z490+PentiumGold when i disable the 4g decoding, it works with 2 cards and shows both as Geforce RTX 3070, once i insert the riser connected to third GPU on the motherboard it enables 4g decoding back and even if i disable it and reboot it comes enabled back, and with that i have it back showing:
0- Geforce RTX 3070
1- GA104 [GeForce RTX 3070]
2- GA104 [GeForce RTX 3070]
3- GA104 [GeForce RTX 3070]

i tried gen1, gen2 and gen3 (the default is auto that was also tried), also changed DMI link from Auto to gen3 or gen2 (there is no gen1 on DMI link speed option).

so the last test with the 2x 1660s are not 100% valid when you have more than 2 cards because once you connect the 3rd then it starts to enable 4g decoding automatically no matter what you do.
for now after took more than 4 hours trying crazy configs in BIOS of the motherboard decided to replace with the B450+AMDryzen and it works with 3 RTX3070, waiting for my pcie splitter arrive to put the fourth vga card, i am not mining with the 4 cards because i only have 3 slots in the amd motherboard now, hoping the pcie splitter will resolve

i already have seen the same motherboard working with 4 cards in other rigs and with HiveOS, it should have something that i didn’t tried, this pentium gold on the z490 have max of 16 pcie lanes, so it should work but all my tries with different configs were unsuccessful, if you find something useful please let us know.

1 Like

hey just figure it out looking closely on this, one of your cards are on 16x.
your processor have 20 pcie lanes, so probably you are using something on USB too that is consuming one pcie lane, you need to get the GPU 4 to be listed with “PCIE Link Width x1” too instead of x16

@ballyhoo that is your issue, there is no more lanes available to the card


Funny to hear about the lanes, that is exactly what I am investigating about right now.
I experimented with the x16 to x4 a few days ago to no avail, but it came to my mind again and I looked at the specs of the CPU, which said 16 lanes for GPU and 4 lanes for the m2 drives.
It could be, that the chipset has more lanes for the x1-slots, but I will give it a try.

Thank you so much for your input.

Nothing changed, no matter what I changed in the BIOS.

But the customer service from ASRock answered, here is what they said:

Dear customer,

It is not about PCIE 2.0 or 3.0, but about the hardware that can be addressed.

The first 2 PCIE slots are connected to the CPU, the other slots are connected to the chipset.

What you need is a function called Above 4G decoding, but this only works when CSM is disabled, and the graphics cards support GOP

Since the new Agesa codes have a number of changes, it can be this function is available in the BIOS, but I cannot tell, each Agesa is different.

There is no Beta BIOS

So I tried again to disable CSM with 4G decoding, this time only with one GPU attached.
It started and mined.
Then I attached one GPU after the other, but with the fifth it denied to start.
It will not even reach the ASRock screen to go into the BIOS.
So I tried with one card to go into the BIOS again, but as soon as the first page of the BIOS appeared, it started again.

What can that be, it’s starting with one card in HiveOS and is mining, but you can’t access the BIOS.

And what is meant with “support for GOP”, the 1660 Super is a current model, so it should have support for GOP, or am I wrong?

1 Like

Hello, having the same issue adding the second 2060 on a ASROCK h110.
still unable to fix it

Have you disabled CSM and set Above 4G decoding?

Have you seen this post?

1 Like

Thanks Christian @ballyhoo.
Glad to have a replay to my question, it is really appreciated.
Tomorrow morning I will go ahead following your suggestions.
I will keep you posted.

1 Like

Quick status UPDATE (I hope this helps who are facing the same issue)

I have been able to fix it and have my rig fully working.

I followed the points that @ballyhoo explained to me, step by step.

I also changed one card power cables and riser.


So, a quick suggestion for the ASROCK H110BTC+'owners… follow step by step the setup guide, power up everything needed and tune the MoBo.


@ballyhoo beer paid, thanks.

1 Like

Glad the instructions worked.

But the credits go to @ihg70 for his in-depth explanation.

I think, the mobo will not work with six GPUs at all.

Last answer from ASRock customer service:

I checked with Taiwan, but , X370 Pro4 supports Supports AMD Quad CrossFireX, we only guarantee 4AMD GPUs for this motherboard.

You can try to disable the onboard audio, and serial port, to see if this frees up enough resources.

Regarding CSM, this only works if the graphics cards are GOP compatible, meaning that UEFI will not detect the card, but the card must fulfill some standards, that are compatible with UEFI.

In this case, the issue is that the cards, do not properly support GOP, maybe a firmware update helps, but only the manufacturer can tell.

One thing is certain, we cannot solve this in a BIOS.

Who has six of these cards running and with which mobo?

So I switched Mobo to MSI B450-A PRO MAX, changed the BIOS to 4G enabled, connected all cards and it works. Halleluja …

Anyway, thanks for all the help I received.

1 Like

I have the same problem with those tu116 - gtx 1660
And i have made like ballyhoo sad .
But in first time it dosent work then ill reset miner and help in such a way that it show gtx 1660 normaly but it dosent started mining , after this ill power of and on and it is anather tiem the same i have b150 m night elf from msi .