More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GPU shows Malfunction

Moved a rig from one spot in the mining shed to another and when it came up, it will only recognize one GPU. Tried all of the normal trouble shooting: unhooked and re-hooked everything, re-check everything in BIOS, upgraded/downgraded Hive OS, upgraded/downgraded/changed miners, swapped/moved/changed out cards, but I get the same as shown below. The motherboard is an Asrock 510. The Asrock shows all GPU’s green on the startup screen, but no matter how many GPU’s or in which slots; only GPU 0 will run and all others show as Malfunction. Anyone got any ideas?

Check each card 1 by 1. Verify all cables/risers are working, and bios settings are correct.

Also, Don’t overclock the core then set a power limit that ends up throttling the core anyway, that’s counterintuitive.

Use locked core clocks on all modern cards instead, no power limit needed.

Swapped all cards in and out, to includes cards not currently displayed and AMD. It is not the cards. The 510 is a riserless motherboard. All cables have been swapped out for different, known working spares.

Do one card at a time, check each slot etc. when do problems arise? After 1 card? After 2? Is it the same slot that works only? Etc.

I have tried 30+ combos. Pretty sure there is some kind of damage to the board. Slot 2 will no hash period, but passes all of Asrocks diagnostics. With Above 4g enabled, only 1 card will hash regardless of with slots. With it disabled, 2 cards will hash. Once I put 3 cards on the board, the BIOS automatically switches to Above 4g enabled and only 1 card will hash. There is probably a setting in the BIOS to stop it from doing that, but it was not obvious to a cursory inspection.

Csm disabled? PCIe gen set?

I’ve had similar issues with cards dropping. It could be your overclock settings, especially if you have switched card positions. One solution I have found to work, is to power down the rig. Then log into hive on a separate computer, and remove all the overclock settings of all cards. Reboot the rig, then reapply the overclocks.

I notice that you are still overclocking by core clock offset. Just over a year ago, hiveos added a feature that will reduce your power consumption, with no/minimal impact on your hash rates. It was designed for Turing and Ampere based cards. So basically anything 1660 super and up. I have two 1660ti’s and two 2060 supers. It lowered my total power usage by 75 watts, and actually raised my total hash rate by 0.7 mh/s.
You can read about it here:

And you can see it being applied here (not my video):

I hope these help with your situation.