Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Gigabyte Vega 64 oc/straps

Hello guys, so I’m trying to get my Gigabyte Vega 64 to a 50mhs hashrate. It’s the one with Samsung memory and I flashed a Vega 56 ROM 113-D0500300-X06 onto it. The problem is that I cannot get anywhere near 50mhs. The power consumption is also higher than the others - I have three Vegas in total and two of them operate on 50mhs and 110-120W, which is very acceptable.

But as soon as I touch straps on the Gigabyte card, it crashes. I also had troubles changing memory clock - the maximum I can get is 945 - as soon as I increase this number, miners report that the GPU is DEAD. Getting to 44mhs was a painful way and I’m happy I got there, but I cannot make any progress ever since.

Any suggestions on what bios to flash and what oc/straps to use?

1 Like

Same here bro.

Try undervolt below 800. Not sure how low can you go without getting too much instability but mine is on 780 and it’s operating with 50.3MHs under 154W. Still pretty high but better than nothing,

I guess you need some amdmemtweak from Vega 56 and Vega 64 guide thread. Please try that.

Also you can try teamredminer with eth_config: B extra argument. It gets a few extra megahash.

What are your current settings and straps?

I followed this guide:

I have the following memtweak all on my vegas:

amdmemtweak --CL 20 --RC 36 --RP 12 --WR 13 --CWL 8 --FAW 12 --RAS 22 --REF 65000 --RFC 249 --RTP 5 --RRDL 5 --RRDS 3 --WTRL 9 --WTRS 4 --RCDRD 12 --RCDWR 12

Core 1000, DPM 3, VDD 780, MEM 920

Decrasing VDD will definitly alter your watt usage. Im not sure how low can we set this without getting too much instability though.

Also keep in mind that watt usage we see in HiveOS on those AMD cards are definitely not the real power draw. It’s just what the driver reporting to the OS. Maybe the Giga Vega is the only one close to the truth.

We should measure them with real ac meters and compare with other vegas.

Tried your OC settings and straps, but the gigabyte card still keeps failing (same error - gpu dead). Is my bios version correct?

I don’t mind the wattage so much, but I’d like to get that one card. to at least 50mhs.

There are a lot of bios versions on techpowerup. I was not sure either which one to go.

I ended up using this one, confirmed it’s working by OP.

My card id is like xxx-xxxx-xxxx or something but it’s working for me. I have the OC version of Gigabyte Vega 64 though.

Also please note I use teamredminer. Not sure what you use.

I also got GPU Dead and 511 errors during setting them up (even with and without this Giga Vega, I just installed this yesterday), but they gone after a while.

Actually my measurements showing lower power consumption than what HiveOS shows.

My total power draw was around 1190 Watt without the Gigabyte Vega64. Today it’s 1300 Watt which gives a 110W difference. That’s not even close to 150-160W what I see on HiveOS.

I guess those numbers on the console are wrong. Your best bet is to measure them one by one.

Alright, so far it seems to me that my Gigash*t card cannot handle any --REF. Tried:
65535, 65000, 26000, 23000, 20000, 17000, 15600, 7000

As soon as I apply --REF, the GPU crashes.

That’s wierd. Maybe try another riser?

Also you may need to tweak your bios. I’ve heard some of those old risers better like if PCIe gen has been set to Gen3.

Also make sure Above 4G encoding probably better to be enabled and disable CSM mode.

You may also can try the bios I linked.

I will stop for now and test further in a few days, had just about enough of it for now.
The best setting that got me to ~46MHs without crashing the card:

amdmemtweak --CL 20 --RC 38 --RP 12 --WR 13 --CWL 8 --FAW 12 --RAS 26 --RFC 239 --RTP 6 --RRDL 5 --RRDS 3 --WTRL 9 --WTRS 4 --RCDRD 12 --RCDWR 12

(not using --REF in the straps, as any REF value crashes the card)
(the specific bios on the image gave me the best results)

Actually can you tell me what do you mean under crashing the card?

I regularly get gpu dead error when I touch the OC settings, especially the voltages but after the reboot it gets up like nothing happened.

Where do you apply your amdmemtweak? Do you apply it through the OC window or you send it like command?

try these settings with teamredminer


amdmemtweak --RC 35 --RP 13 --RAS 22 --REF 65500 --RFC 148 --RRDL 4 --RRDS 4 --RCDRD 12 --RCDWR 4


amdmemtweak --CL 20 --RC 36 --RP 14 --WR 14 --CWL 8 --FAW 12 --RAS 22 --REF 65000 --RFC 249 --RTP 5 --RRDL 6 --RRDS 3 --WTRL 9 --WTRS 4 --RCDRD 14 --RCDWR 12

The card crashing = an error message saying “GPU: detected DEAD”

The way I apply settings is that I undeploy flight sheet, change settings through the OC window, then reboot the rig, and then deploy flight sheet again.

For me, after deploying flight sheet, the card is detected as DEAD, and then the rig reboots automatically and the card is no longer recognized. Have to do aditional reboot so that the card is loaded, but it crashes again.

Won’t help mate. Any --REF value included in the straps will crash the card.

Can you share what MOBO do you have? Also are you using pcie splitter or something?

Actually i have a pretty similar rig like yours and i’ve just installed this giga vega 64 as my 7th card yesterday and i’m also facing with a problem that adding a 7th card to my rig was not that easy.

I’ve just experienced some similar random gpu dead errors recently when i tried some massive undervolting on my other cards as well.

I have ASRock H110 Pro Btc+, and I’m using a 1650W power supply with 16 PCIe outputs, so no need to use splitter. The three vegas in my rig have 2x single (non-split) PCIe cable connected to them, so the amount of power they are receiving is not a problem.

I have 4 VEGA´s, one of them is 64 with the BIOS from the 56 (GPU1).
I only have the GPU Dead issue with GPU5, I tried many OC settings but I dont know that the straps could be a problem?
My feeling are the straps not ok you get some invalid shares?

–CL 20 --RAS 22 --RCDRD 14 --RCDWR 4 --RC 36 --RP 12 --RRDS 3 --RRDL 5 --RTP 5 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 65000 --RFC 249

–CL 20 --RAS 26 --RCDRD 12 --RCDWR 12 --RC 38 --RP 12 --RRDS 3 --RRDL 5 --RTP 6 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 24000 --RFC 239

To those having troubles finding the right Straps or OC.
Follow this.

I see a waste when i see a vega 64 flashed to 56 only running between 45-50 megahash.

Mine runs stable. The Asus would throw some 1-2 invalids a day but i can live with that.

you’re losing at least 5-6 more megahashes.
Follow my guide.

1 Like

I have the same card and its complete garbage. It will mine ERG with no problems, but ETH it crashes all the time… Thanks for the heads up on the --REF strap as I couldn’t get the card to stay stable for more than 10 seconds and it was driving me nuts!

1 Like