Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Did I break my card?

Hi world, I’m looking for final judgement. Recap:

AMD 6800

Mining all good at 60/62 m/s.

Put together with another 3 3070s using 2 PSU 850w+650w, all of sudden card not recognized if not as NAVI 21…NOT MINING.

After messing with bios restore and hiveos old version and update amd driver 16.04 card is recognized. But hashrate 20 m/s and 135w…not cool.

If I overclock, card crash.

Just tell me “You broke it” or “Actually…”. Please I need confirmations of any type that I waste this card or if I can get back to hope.

Thanks in advance for your time

what have you done to troubleshoot? swap risers? try the card by itself directly on a board?

hi, thanks for your reply.
i have done the following:
tried on the board of my linux(hiveos) system
tried on another windows system
change risers, psu, everything
i personally think is the card, i even check the bios ID and all of that, i have notice that the bios on it is for 6800xt gpu, even tried to flash a bios for a normal 6800 but amd software blocked me so nada.
so here i’m again, on hiveos, try to get back as i was at the begin.
i’m upgrading the hiveos system to the latest version and the result is the worst, the card comes out as NAVI 21 meanwhile when i’m with the hiveos version 0.6-205 at least the card is recognized.

So not sure what I have done different but now the card is recognized and it mines at 58 m/s, 130 w

No overclock applied yet, I’m really scared to apply the OC, but I’m sure I won’t resist the temptation.

Anyway I think the GPU is not broken after all.

I think new hive versions are messing with RX6800. To get that 6800 in 61.5-63 mhs try fstate script

First pause.

Latest Hive Kernel(#72) put the F-state in there @ 1551 for 6800’s:

Changing versions will not impact what is happening with that kernel as it includes drivers and recognition of 6800’s.

BIOS Changes to 6800’s are speculative at best and were attempted as a means to lock in F state and a few other “straps”. Have not seen great long term and sustainable solutions in the 6800 BIOS modding direction. 6800XT’s? Maybe, I don’t have any experience with them personally.

What does amd-info show you about your GPU?

here is my amd info.
sorry if i pass for a massive noob, (which actually i am), but how do i put the “fstate”?

for the bios ID, which don’t appear on hiveos for some reasons, is, i checked it with GPU-Z.

here a snip of my situation at the moment

thanks again in advance for all the support

You are on the latest stable kernel(#72).
The GPU f state is already maxed at 1551 as I suspected, no need for a “script”.

In my opinion, Core is too high to start working with that cards specific needs and memory is too low. (Defaults it appears since there is no entry?)

These are mild as a baseline to work up from(some of the voltages may be a bit low for a flaky 6800, 660/760/1275 may be a necessary bump) :

Which miner are you running?

hi, i was just about to try these OC setting, and the 6800 failed and i restarted, and guess what…NAVI 21 again.

just to give you some extra info, yesterday after upgrade to the latest version of hiveos i updated the amd drivers with the script from cryptoluigi and selected the driver at number 14.

btw: Forgot to mention, Gigabyte masks their BIOS as a manufacturer. Not unusual for them.

What is the specific expected benefit of a driver change from the latest OS kernel+Driver? There are risks with such changes, they should be offset by some quantified benefit.

6800’s are not new and have been stable for quite some time. One of mine since the 211102 update with the latest stable kernel and drivers:
Image 11-30-21 at 1.06 PM

Which miner(s) are you running in your hybrid rig?

fwiw: If it were my rig, I would return it to latest stable kernel and run the drivers included with it. Neither the 6800 or the 3070’s are new.

i’m using nbminer at the moment with this rig, i will take your advice and stopping from update the drivers with the script.

so now the only thing that seems to work for having at least the system from recognizing the card seems Hive replace, but still i’m trying to set the OC at the start of the rig and that seems to crash the rig.

Image 11-30-21 at 1.56 PM
fwiw: I am running this version in my test bench / hybrid rig:

  • for nVidia tool support, thermal throttling indicator works for our 3xxx series.
  • I am running latest T-Rex and Team Red Miner.
  • In addition, it has what looks like the latest nbminer update in the changeling list, if that remains your miner selection.




  • Added display temperature of memory for Nvidia GPUs equipped with HBM/HBM2 memory e.g. A100, CMP 170HX, etc
  • Updated nvtoolto v1.57 (added memory temperature reporting using option --memtempfor GPUs with HBM/HBM2 memory; added option --throttleto show throttle reason which also reported by nvidia-infotool, so you can look all info using it)
  • Updated PCI IDs to v2021-11-20
  • Updated amdmeminfotool to v2.1.16 (added new & fixed some AMD GPUs names)
  • Fixed GPU detection on some server motherboards
  • Minor fix for srebootcommand
  • Fixed bug with CPU-only rigs when there is no GPU in the system at all
  • NBMiner v40.1 (added support future LHR GPU models; display current LHR value in console summary table; option proxynow support username & password for SOCKS5 proxy, format: "proxy": "user:pass@host:port"; CPU share validation processed into independent thread; fixed LHR lock detection failure on some cases)
  • NanoMiner v3.4.4 (improved performance of RandomX)
  • WildRig-Multi v0.30.6 (one more round of heavyhashoptimizations, up to 10% on some GPUs; fixed duplicate Nvidia gpu’s on some systems)
  • lolMiner: more clearer message when the GPU fails
  • CPUMiner-Opt: fixed hashrate units

ehi, thanks a lot for you info, at the moment it’s running, thanks god, i use your oc settings and i have this results:

not top but ok for now, give him 1 day and i may tweak some of the settings for the amd card, not sure why now the nvidia are not performing well, must be the latest version of nbminer the problem.

I’d let that AMD run awhile as well.

  • fwiw: When the time comes to tweak, I’d likely try 1289 Core/1064 Mem then 1300 Core/1068 Mem.
  • fwiw2: You are not alone, this is my most troublesome 6800 series, always temperamental and note the voltage values :frowning:

I have moved my nVidia clocks to fixed values versus “-values” in the same software versions you are running. Unfortunately, I don’t know the 3070 values :frowning:

Related note: Might want to check out the new feature to be entered in via hive shell:

nvtool --throttle
Image 11-24-21 at 6.55 PM

so, now i understood that my card is not broken, but what’s happening is that everytime i reboot the card become unrecognized with that bloody NAVI 21 on it, so again only option to resolve seems to reflash hiveos image and hope for the system to start with no problem, is it normal? or i’m just lucky?

Hello, I’m having similar issues with ASrock Phantom Gaming 6800 cards. Some times the system boots up, and after the grub screen (blue screen before hive os screen) the amd drivers crash and the rig freezes. since you have the nvidia cards too I think yours keeps going. At this point I think hive os is no good for 6800 cards.

With the driver 14 of the list you said, are you getting low hash rate but always working? I think you need to add fstate script to that installation.

also, I think you dont need to reflash hive. Just cut the power of the system and boot again, and again and again and eventually it will boot up (if you issue is the same as mine)

how do i do that?

now i have this situation:

go into hive shell, or via local network at https://local.ip:4200 and type amd-info