Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Ccminer forks

There are a number of forks compiled and available.

Due to big file size of the binaries (20-70mb each) they are not included in default installation of hive. They are downloaded automatically when you choose ccminer fork in the wallet.
If you know that there is a new compiled binary then you should run


on the rig which will check current version and a downloaded one.

Repository links for information what is what.





Good for neoscrypt














zp (for ZEN)

Download link for manual installation

If you have replaced the file and it says “Permission denied” then you did not set “Execute” permission to file. Open file properties and set “x” bit.

How to install new miners? CCMiner not alows to me to set the launch config, with someting like 24 threads and 21 blocks. (like xmrMiner)

You download the file, open WinSCP or other ssh client and replace the file in /hive/ccminer

Don’t forget to make the file executable too after uploading it :slight_smile:

Could anyone give more detail to this? I replaced the default ccminer-tpruvot-224 with ccminer-alexis but it didn’t work

chmod 777 for ccminer-alexis bin file.

нужно переименовывать файл в ccminer-generic? или он запустит ccminer-xevan например?

hey guys for lack of instruction for new ppl to linux which was/is my position too…

i found this and it might help you to install the fork for alexis…works for me :slight_smile:

cd /hive/ccminer223-cuda90
miner stop
mv ccminer-alexis ccminer-generic
chmod +x ccminer-generic
miner start

im also guessing its pretty much the same for the other forks just change the folders/names accordingly :slight_smile:


I do not manage to install the fork ccminer-klaust

I do not have to have the good method. I am new on Linux.
This is what I make step by step.

Miner stop

1/I copy ccminer-klaust in the file hive /ccminer223-cuda90 with WinSCP

2/I rename the file ccminer-klaust - > ccminer-generic

3/With putty, I throw the command : chmod +x /hive/ccminer223-cuda90/ccminer-generic

I also tried cd /hive/ccminer223-cuda90
then: chmod +x ccminer-generic

Needs to delete ccminer-tpruvot224?
Needs to change the octale value of ccminer-genric?

miner start, always tpruvot224


I tried in property, and put value “x” has ccminer-klaust and to remove value “x” has ccminer-tpruvot224.

And I have

Hive/ccminer/ line 5 acces denied

I admit that I am lost.

Sorry for my bad English, I am French and I pass by a translator.

I succeeded, made it is simple.

miner stop

Delet ccminer-tpruvot224 by ccminer-klaust.
Marked all the “x” in properties.
Especially do not forget to modify the shortcut ccminer and edit it ccminer-klaust.

miner start

happy mining :slight_smile:

What about this fork?

phi-anxmod doesn’t seem to work:

Cuda error in func ‘skein512_cpu_setBlock_80’ at line 565 : invalid argument.
Cuda error in func ‘scanhash_phi’ at line 142 : driver shutting down.

I can help and report this, but someone please confirm.

Any chance to add palgin mod?

Is it possible to have an easier install of the forks? Say a command where you can install specific/all forks at once?

Hi there,
phi-anxmod does not work. I guess that it has to be compiled with cuda 8.0, not 9.0. Any chance for that to happen?

Thank you very much for the fix for phi-anxmod :slight_smile: :slight_smile:

What kind of algos are the best with ‘phi-anxmod’?
And BTW I have no chance to run ‘dace-cryptonight’. It is simply not starting after putting all settings. Where I can found logs to see what is wrong?

Are these steps still required? It looks like when the fork for the miner is selected (sp-mod in my case) it’s downloading the miner to the local machine. I’m having trouble launching, and I’m not sure if it’s in my config or ccminer, I already see a ccminer-sp-mod directory after watching it download.

What miner fork is the best for neoscrypt? :slight_smile:

Sp-mod fork for ccminer does not work for some reason. Can anyone tell me what to do. As this fork gives 10% more hashrate on phi. At least under windows :slight_smile: