Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Autofan: GPU temperature 511 is unreal, driver error



I just switched to HiveOS 3 days ago, and I’m facing a problem.
I’ve a rig with 8x RX570 4Go, all the card have the same vBios.

On first boot, all is ok, the 8 cards is detected.
I setup the autofan with a target temp @55°C.
After a few hours of mining RVN with TeamRedminer I got this error:
Autofan: GPU temperature 511 is unreal, driver error
I check the log and I get this:
00:02.0 Temp: 0C Fan: 0% Power: 0W
01:00.0 Temp: 63C Fan: 100% Power: 112W
02:00.0 Temp: 511C Fan: 100% Power: 16777215W
03:00.0 Temp: 55C Fan: 47% Power: 109W
05:00.0 Temp: 56C Fan: 100% Power: 112W
06:00.0 Temp: 57C Fan: 100% Power: 114W
07:00.0 Temp: 57C Fan: 100% Power: 111W
08:00.0 Temp: 56C Fan: 87% Power: 111W
0a:00.0 Temp: 58C Fan: 100% Power: 109W

I reboot the rig, but it only detect 7 cards.
I have to shutdown, disconnect all the cards except the 2 firsts (Pcie x16 1 et Pcie x16 2)
The 2 cards is detected.
When I reconnect all the card, the card connected to Pcie x16 2 (the card with lead to the 511° error) is not detected anymore.

It’s not a OC problem, or riser problem. I change the card and riser and all card connected to Pcie x16 2 is not detected and if she is detected lead to a 511° error.

When It work, I see the fan is always 20-30% more speed than other card (all have the same vBios and fan settings)

So the problem is the Pcie x16 2 port.
I have a ASUS PRIME Z270-P with 2 converters M.2 Pcie 1x.
Before on Windows, all work fine without any problems.

Anyone has already got this problem?

Thank you !

What motherboard in use?

Did you solve the problem???

Same Here

I am having the same problem. Does anyone know the solution?

same problem here with 4 rx580s if someone knows a fix

Not sure if it applies to all of you, but probably for some at least, it was my case.

The PSU is not up to the task even if it should be powerful enough - I have 2 650W, one Silvestone 80 Plus, one Gigabyte 80 Plus Bronze.

The Gigabyte was running system +3 GPUs and Silverstone only 3 GPUs.

However the Silvestone was getting overheated and shutdown. I rewired the system and let the Silvestone handle only system +2GPUs and that fixed it.

Sure, not a good setup on my part, but the insulation/ventilation of the PSU is bad and it doesn’t handle as much as it should or other similar PSUs do.

I’d the same issue, my setup was 6 RX580 8GB GPU(Red Devil Golden Sample) with Antec 1300W power supply. My riser cards were connected with SATA cable and I was powering 2 GPU with single SATA cable (BAD SETUP)

My interim solution was to connect 1 GPU with 1 molex cable and thats kind of help and worked until I got the 6pin cable. Also on Undervolting/ Overclocking my all cards behave differently though they all have micron memory and I bios moded them same time, so below is my setting for 6 gpu

HashRate Temp CoreClock CoreVolt MemoryClock PowerDraw
32 51 1200 800 2200 99w
32 57 1200 800 2200 102w
31 72 1150 800 2100 135w
31 72 1140 800 2090 127w
32 57 1190 800 2190 99w
28 73 1050 800 2000 123w

Hope this will help.

Same problem with Vega 56 samsung memory.

You have huge difference in wattages, I’d check amd-info to make sure the OC is applied correctly. From my experience the settings I make on the web interface to OC don’t apply correctly like 50% of the time.

Here is my amd-info, for me if I apply setting in Web UI it does works.

How do you know? What you showed here (first picture) is not amd info. For that you have to type in “amd-info” into console. Then it’s gonna show you detailed table with real overclocks. I was setting up one rig today for example and it took like 3 tries to get the OC right. It could also be sillicon lottery, but the differences are wild, I bet on OC issue

Here its the actual overclocks

Core & Mem exactly same as Web UI

See, the mem and core clock maybe, but the voltages dont match. They are way to high actually, thats why you have such power consumption. Try and start with 850mv for both mem and core (800 is too low and would cause crashes/freezes actually). Something like 1100/850 and 2000/850. To get higher hashrate play with memory (core doesnt affect it much and 1100 is fine). You have to find a balance for clock and voltage, every card is slightly different. Most of my cards handle 2100/850 but one doesnt, so i had to lower the clock slightly. Start lower and note which card crashes when you tweak the settings, then you know to leave the card at lower settings and you can keep cranking up the rest a bit until you get the highest stable performance from all of them. Remember to confirm the voltage with amd info first. Once its correct, play with clock mainly and if you want to squeeze more hashrate, add some juice in small increments like 850>865>875 etc, but beware, the more volts, the more power consumed and at some point the increase of hashrate gets less effective per watt change

Many Thanks, I’m able to stabilise the volt now, here are the final settings,


Hey everyone my error was from one riser not being fully locked lol so please check this to save yourself the headache. hopefully this helps some people

I have seen the issue. It seems to be related to the risers I am using. I have touched a piece of equipment felt static, and the unit tripped, fans to full speed, unreal temperature 511 error. Looking at how to improve grounding.

1 Like

hi, did u solve it?

I am having the same problem. pls hel me

Solved after changing riser. The blue risers common on amazon seem to have issues. The other problem I had was overloading the 20 amp circuit that feeds my three rigs. I was not tripping breaker, but power was dropping and one power supply would go down momentarily.

New risers and multiple circuits, not more issues.