Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asus TUF Gaming RTX 3090 OC - can't have stable hashing


I have a small rig with 3 cards, 1 RX580, 1 3070 and 1 3090 which I just got. All this on a H110 Pro BTC+ motherboard, 8gb ram, Intel Celeron and 256GB SSD. I have 2 PSUs at 1000W each.

I can’t get the 3090 to hash for a long period of time and always causes the miner to reboot (GPU drivers no temps error).

I also tried no OC, OC with all possible options I could find (the one in HiveOS, miningchamber and some settings here).

Any suggestions? Overheating? Do I have to change thermal pads? Seems like what my options are pointing towards…

Thanks for the help!

Try my settings, I have been stable for well over a week on t-rex miner. You also have to set the 3090’s power limit around 7-10watts higher than the actual readout. I used to have mine set at 305 watts and it would crash, no problems when set to 310.

thanks trying as we speak.

which miner? I use phoenixminer 5.5c
which nvidia drivers? stock on the hiveos image @ 460.67
which hiveos version? upgraded to 0.6-203@210503

I use both the latest versions of hiveos and t-rex miner. My 3090 gets about. 5mh/s higher when I use t-rex, all my nvidia cards run a little higher on t-rex. I run my AMD cards through phoniexminer 5.4c

what about nvidia drivers?


it didnt work, crashes within minutes.

I set the mem clock to -1000 and get something stable at 101.7mh/s since 40 minutes.

still cant get it to work properly. the card is an “OC” model so maybe it runs too fast stock? it rebooted the OS and the miner quite often yesterday so I took it out of the flight sheet.

I will try the rig on Windows OS for a few days to check if I can get something stable out of this 3090

ok so regardless of the miner, drivers, OC setting the 3090 wont be stable. I was able to get a screenshot of the processes running (LA was around 9) and gminer stopped working on the 3090 and eventually took down therx580 and 3070 (each on different miners).

the ‘top’ command through shell clearly shows the miner using all CPU

where can I see the logs and try to pin point the issue? else I will move to another OS…

last settings…did 1 hour on them before the LA went RED and rig rebooted

if the LA is spiking and it’s clear it’s from the miner itself from your screenshot then whilst in console tpye command miner and watch the live miner output to see whats going on. You could also enable logging which would hopefully capture the event prior to rig rebooting. Do you have any watchdog’s running on the rig itself or the miner ?

Hive itself has a watchdog inbuilt if you have enabled which would issue a rig reboot command when the LA reaches your set value.

Also with the 3090’s they are not very efficient cards to mine with and plagued with thermal throttling issues dependant on the brand of card you have. My best advice is put it on ebay and sell for upwards of £2500 to someone who dosen’t know which cards to buy for mining. You would be far better running 2x 3070’s or 2x 3060ti’s than 1 x 3090 and achieve the same hashing for less power.

The 3090 in some overclock variants also have a TDP of 420watts so its worth also looking at your power setup to this card and other cards setup on the same PSU. Remember your risers would also draw about 54Watts each.

for now, it’s what I have…trying every day to get a better GPU but we all know about the shortage.

I can get almost a full day if I underclock the core to -300 and Memory to -500 with fan at 100%, PL at 73%. This gets me 100mhs…GPU is around 38-40 celsius

I ordered heat sinks and will put them on the back plate where the ram chips are. this could get me a few more mhs

oh and this is on Windows 10 with trex and afterburner. I run trex individually for each RTX and teamred for the rx580 so if one miner crashes, the rest continues to mine until I restart it

if your running individual physical miners for each gpu in your system this is undoubtly why your load average is so high and your cpu is maxxed out etc. Your system would build a dag file for each miner as my first thought. Also you would be running so many miner instances that you would be utilising a lot of cpu threads as opposed to minimal by using 1 or 2 mining processes when you need to split between nvidia and amd on the same rig. You can defo get the 3090’s stable and your temps are already very respectable so i would assume your issue is not a heat one at all and more an issue with your cpu simply being maxed out with all the processes running from the different mining instances.

what motherboard , cpu and ram are you using ?


I get the same using phoenixminer for all 3 cards (1 instance)…The 3090 would hash fine then drop to 0.00mhs for a while then miner would restart.

I have a AsRock H110 Pro BTC+, 8GB RAM, Celeron G3900 (2.8GHz) and 256GB SSD.

Right now, CPU is between 5-10%, RAM at 50% and plenty of HD space…

My settings for the TUF GAMING 3090:

Core -300
Mem 2500
PL 340

I have a stable 123.1Mh/S as you can see. Give it a shot :slight_smile:

i am getting low hash rate

Still not able to cross 94

when i remove all oc setting i get 100+, So how i get to 125mhs, please help

With all 3 pictures that you sent, I see that our 3090 is not using its full potential because it’s only using 269w when it should use around 340w.

Few things come to my mind.

1°) Do you have enough wattage from your PSU to run all your cards?
2°) Did you check that all cable going from the PSU to the GPU and from the GPU to the risers are well connected?
3°) Did you try to swap your risers?
4°) Did you update to the LATEST NVIDIA DRIVER? (I see that you are using the version 455.45.01 and I am using the version 460.67.
Your problem might be coming from that.
To do update your Nvidia drivers, check this out:

Tldr: Command shell and type: nvidia-driver-update --list
Select the latest stable driver by typing the version and reboot your rig.

5°) Try switching your mining software, I am using T-Rex Miner and I have no problem, try others, that may fix your problem.
6°) Try downgrading your HiveOS version, I had the latest HiveOS but it didn’t detect the RX 6700XT so I had to downgrade it. (not too convince about that one but you got to explore all posibilities)
7°) Open your GPU and check that everything looks normal inside (you can switch some thermal pads while you are at it :wink:
8°) Your GPU might be throttling and that’s why you are getting low hashrate, it’s simply too hot for the Memory to handle.
The 3090 are really really hot, so try to give your GPU as much airflow as you can.
If you can boil an egg on the backplate, it’s too hot.
I can’t let my hand my 3090 more than 1 sec and the core is at 50°C, so when I see yours at 61°C I imagine that your GPU MEMORY might be very very hot.

I put my AC right in front of my rig so that’s why it’s not that bad.