Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asus Strix ROG RX 5700 XT bios mod not working!


I’m struggling to get my Asus ROG Strix cards to work after putting a new bios in. I have used Red Bios Editor and AmdVBFlash. Every time I flash it seems to work the i get code 43 error after restarting. I’m a bit of noob but my mate is a guru has been trying also. He tried modded bios’s and atipatchutility with no luck. Has anyone got this model working? Would really appreciate some help!

1 Like

Contact me directly on DISCORD Jarek2805#1625.

hi … i have the same problem with mine. I manage to modify a BIOS with RBE but once flashed the card no longer works, so return to the original BIOS and it works again.

Hi Jarek can you send your discord handle again?
That one wasn’t working.

Apparently it is most likely a bios signing issue. My friend used to come across it in older AMD cards and use ATI patching utility to fix it. Unfortunately ATI patching utility not working on this card now.


Same situation here with the same GPUs, I just downloaded the Vbios and modded it with Red Bios Editor. Uploaded through hiveOS and after the reboot, my computer doesn’t even POST/BOOT, Stuck in a constant black screen. Luckily (thanks to the dual bios switch) restored the Stock ROM switching to the silent bios.

Will be nice if someone else has the solution for this as I’m mining just on overclock at 53,8 MH/s :confused:

Edit: I´ve found this guy apparently flashing the same GPUs with the same software, the only thing is that is in Russian and I don’t understand a thing lol

discord Jarek2805#1625

Hi jarek , i have send you an invit on discord … (Narno#8141)

Invitation sent. Thanks.

Resurrecting this thread to say that I managed to get my single Asus strix 5700 xt OC BIOS modded by first downloading an earlier BIOS from techpowerup (Asus.RX5700XT.8192.190927.rom) then modding this BIOS then flashing.
This worked.
I believe that Asus might have started using BIOS signing in their later BIOSes which is why they werent working.
Hope this helps someone.


hi machasm, thanks for your post, but it doesn’t work for me. can you explain how you did it ? you flashed under hiveOS or windows?

there is something i must do wrong for the ASUS because my nitro sapphire i have no problem for modding the BIOS

So what I did was download the Bios for the 220W card dated 27th 09 2019.
I then flashed that bios first to see if the card would boot which it did.
I then modified that bios with the memory strap mods.
I then flashed that bios and all was well.
I did all the flashing through hivesOS


this is what I did too but the results were the same, no improvement over the original BIOS. what results do you have with your modified BIOS? I am at 54.37Mh/s with 109W

did you modify your BIOS with RedBiosEditor?

Yes I used RBE. Current hash rate is 58Mhs at 124w

1 Like

I don’t understand why it doesn’t work for my asus while for my saphhire it works

Try flashing the bios to the quiet bios rather than the performance bios.
In other words make sure the bios switch is clicked towards the back of the board rather than the front (the front is where the locating screw is, hope that makes sense).

1 Like

Thanks. This has worked for me too.

1 Like

Came here to add that @machasm’s workflow was successful for me, with a minor tweak that I’d like to mention given the various guides to flashing 5700 XT’s on YouTube.

Some context: I’m relatively new to mining, and am in no way an expert on this. This is just an attempt to jot down what my personal solution was for my Asus ROG Strix 5700 XT OC that seemed to be maxed out at ≈51.4 MH/s (1430 cc; 750 mV; 905 mem) mining ETH on nanopool via TMR.

  1. I attempted to flash via Red Panda’s (awesome) step-by-step guide, using amdvbflash 3.04+ and my modified ‘stock’ bios ( It reported a successful write but booted to a black screen.

  2. I recovered by flipping the GPU bios switch from Q to P > rebooting > switching from P > Q, and then reflashing my original stock bios.

  3. I then stumbled upon this thread and attempted modding and flashing the Asus.RX5700XT.8192.190927.rom (bios version: via amdvbflash 3.04+. I got the same result.

  4. After a bit more digging, I came across FinTech Repair Shop’s video, where he states that he had to use amdvbflash 2.93. I attempted the @machasm’s process again, and I’m good to go Currently running at 55.2 MHs at the same settings (1430 cc; 750 mV; 905 mem), likely with room to improve.