More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

1660s Hynix 37mhs

Hello, help please friend, for the palit 1 fan 1660 SUPER StormX NE6166S018J9-161F, will it work? have you seen reports of this stormx model? Thank you I also have asus TUF 3fans

Hello, I have 3 asus just like yours 90.16.4F.00.73 thanks for your report, but tell me you did it for hiveos or windows -6 what are you talking about? And yours is stable? Thank you

hi there… can i have the card original bios? GV-N166SOC-6GD

GV-N166SOC-6GD

1 Like

THX!!! worked nice…hope there will be a better bios for the unlock of the full hash :x:

My best stable OC.

1 Like

1660S Super Asus Phoenix (1Fan)
Before;

After Palit Bios;

Testing Stability on these settings, copied from hiveOS community.
3.5Mhs increace with almost no efficiency lost.

Flashed with Hive OS.

THAT IS AWESOME! I will try flashing mine now

1 Like

@ssross I have the same card. Was the config you applied stable?

Anyone have a sweet spot overclock profile for stability?
My 2 x Asus 1660S Phoenix OC (1Fan), been doing really great.

1 of it was stable for 2 whole days at 1035 core and 2200 mem (35.12 Mhs) - Lowered to 2100 (been stable for other 2 days at (2100) ~ 34.95 Mhs
the other same model, in 24 hours crashed twice with this settings (Err - Fan Error), lowered mem in 100mhz steps, now it’s at 1900 mem ~ 34.50Mhs

Any tips?

Did you do this from a command line, or with the HiveOS gui? I get an error when trying to flash in HiveOS; I tried in maintenance mode. I’d love to not have to grab this Asus Tuf 1660S and throw it in a windows box.
Can anyone do a quick write-up on how to flash in HiveOs?

Here’s what I did:

As sugested by @asukahan I upload a file to somewhere that would respond to a wget request. In his case (scroll up to check) he used a machine inside his local network, I used AWS S3 instead (you can create a free account or probably use any other cloud storage with some research (onedrive, google drive or dropbox)).

Step by step:

  1. Go to worker options → Maintenance Mode Without Loading Drivers

  2. Go to Power Actions → Reboot

  3. Once your worker is up again, go to ‘remote access’ → Hive Shell Start

  4. Once you shell is ready (check you hive log msgs) open it through the tiny square that you’ll see on the log

  5. It will open a separate browser window, wait for it to load and then type the commands in the following order:
    cd hive
    cd sbin
    sudo wget https://www.your-host-option-s3-onedrive-dropbox-whatever.com/Palit_GTX1660SUPER-6G-90.16.59.00.28.rom
    sudo nvflash_linux -i0 -6 Palit_GTX1660SUPER-6G-90.16.59.00.28.rom

  6. restart to normal (non maintenance mode) and be happy

ps1: you’ll have to do the “nvflash_linux -i0 -6 Palit_GTX1660SUPER-6G-90.16.59.00.28.rom” part for as many times as your number of GPU’s - beware the “-i” is a zero-indexed parameter so your first VGA should be zero and so on)
ps2: You’ll be asked to press ‘Y’ twice for each GPU to confirm the BIOS rom name etc
ps3: dont forget to download and backup your original ROM, just in case…

Mine are all ASUS TUF 2 fan model

2 Likes

I have the exact same Asus Tuf 2 fan model. Thanks for the write-up! You wouldn’t happen to still have the link available would you? I only have one card to do…:slight_smile:

Bro can you create video tutorial thanks.

Yes please make a video… this would be very helpful for us noobs…

like this e bet :slight_smile:
https://medium.com/@jgonzi/change-bios-1660s-in-hiveos-ced2955f5659

Followed the instructions; I renamed the Bios to “Palit.rom” for simplicity.
My 1660 Super (Gigabyte TUF 2 fan) is GPU3 (i.e. the 4th device from the top):

[email protected]:/hive/sbin# nvflash_linux -i3 -6 Palit.rom
NVIDIA Firmware Update Utility (Version 5.692.0)
Copyright © 1993-2021, NVIDIA Corporation. All rights reserved.
Checking for matches between display adapter(s) and image(s)… Adapter: Graphics Device (10DE,21C4,1043,8787) S:00,B:05,D:00,F:00
EEPROM ID (9D,7014) : ISSI IS25WP080 1.65-1.95V 8192Kx1S, page
EEPROM ID (9D,7014) : ISSI IS25WP080 1.65-1.95V 8192Kx1S, page
WARNING: Firmware image PCI Vendor ID (0000)
does not match adapter PCI Vendor ID (10DE).
WARNING: None of the firmware image compatible PCI Device ID’s
match the PCI Device ID of the adapter.
Adapter PCI Device ID: 21C4
Firmware image PCI Device ID: 0000
WARNING: Firmware image PCI Subsystem ID (0000.0000)
does not match adapter PCI Subsystem ID (1043.8787).
WARNING: None of the firmware image compatible Board ID’s
match the Board ID of the adapter.
Adapter Board ID: 01B2
Firmware image Board ID: 0000

NOTE: Exception caught.
Nothing changed!

Very weird! Mine are all 1660s so I had no problem finding the correct indexes. I think you are using the wrong one!

would you please use the command nvflash -a ou nvflash --list and paste the result?

EDIT: The command might be nvflash_linux --list ou -a cuz of OS

Vini I just swapped this into a Windows box and ran the update. If I get more than 15 min into something and I know another 10 will fix it for sure, I go that route. I’m old.
Anyway, nice little upgrade.
Since during this trial phase it’s replacing the 3070 in my main workstation, we’ll see how it goes.
Right now, set to Core 0, Mem +1200 (Windows 10).
35.7 Megahash at 85 Watts. Nice little 3 megahash bump at the expense of 15 watts. Would make that deal every time.
I really appreciate all your help sir!

1 Like

Vini’s method works.

If you’re using wget and Google Drive, you will need to follow these steps: Download Google Drive Files using wget | by Anjan Chandra Paudel | Medium

The three cards posted below are identical, the first one has the modded BIOS:

This method is very convenient if you don’t have time to take out the card from your rig and move it to a Windows box just to mod the BIOS.

1 Like