Increase your income with Hive. Invite your friends and earn real cryptocurrency!


XmRig miner for Raptoreum

Added support for xmrig 6.16.2

New XmRig v 6.16.2 is released

Hive updates - Telegram

XMRIG Miner Doc´s
Read known issues GITHUB

## Performance

While individual algorithm implementations are a bit unoptimized, XMRig achieves higher hashrates by employing better auto-config and more fine-grained thread scheduling: it can calculate a single batch of hashes using 2 threads for parts that don’t require much cache. For example, on a typical Intel CPU (2 MB cache per core) it will use 1 thread per core for cn/fast, and 2 threads per core for other Cryptonight variants while calculating the same batch of hashes, always achieving more than 50% CPU load.

For the same reason, XMRig can sometimes use less than 100% CPU on Ryzen 3000/5000 CPUs if it finds that running 1 thread per core is faster for some Cryptonight variants on your system.


CPU cpuminer-gr-avx2 (tuned), h/s XMRig v6.16.2 (MSVC build), h/s Speedup
AMD Ryzen 7 4700U 632.6 733.1 +15.89%
Intel Core i7-2600 496.4 554.6 +11.72%
AMD Ryzen 7 3700X @ 4.1 GHz 2453.0 2496.5 +1.77%
AMD Ryzen 5 5600X @ 4.65 GHz 2112.6 2337.5 +10.65%

Linux (outdated) (tested by Delgon, detailed results here)

|CPU|cpuminer-gr-avx2 (tuned), h/s|XMRig v6.16.0 (GCC build), h/s|Speedup|

|AMD Ryzen 9 3900X|3746.51|3604.89|-3.78%|
|2xIntel Xeon E5-2698v3|2563.4|2638.38|+2.925%|

Update came out today with 6.16.0 support but when i switched to it getting read error: " end of file " error

i am too getting the error. Not sure what wrong i am doing here…

Nvm i forgot to add the algorithm in the flight sheet setup. It’s working now

1 Like

which algo? can you please share the flight sheet snapshot?

Didn’t have the algorithm selected

Hi I’m having the same problem as well. Have you got any luck yet?

Miner Xmrig (New) ChostRider
Refer your pool for url details, should be easy as select your pool and flightsheet per image and thats it.

Have the same issue, have you managed to solve it?

what issue u have? Have you upgraded hive to latest ?
Algo is XmRig (new) GhostRider RTM

If you use SSL connection enable “TLS”

Issue is same as Minercold mentioned above.

HiveOS is updated to latest version 0.6-212@211128.

Looks like your on windows, im linux so no need for those configs but exitcode is defo caused by wrong config. Have u tried conf wizard to create conf file…
Hope u get it working,looks like its nothing special compared to cpuminer tho,well i quess that it depends on what cpu you run. Sorry that couldnt help…Good luck

Managed to solve it.
The issue was not with the configurations,but something probably got stuck in the HiveOS configs.
I created a new flight sheet ONLY for Raptoreum using XMRig, it started successfully and then updated the same flight sheet by adding the ETH miner and restarted it.
@Minercold you should try this as well I think.

1 Like

Re-select the pool and re-adjust the miner.

Re-select the pool and re-adjust the miner.

I ran into the problem. Seems to happen if you’ve never run XMRIG before. I made a quick flight sheet to mine monero with xmrig then program started up fine. Then changed flightsheet to mine RTM

its already avail in hive

Yep, thought of the same.
My solution was to create a single flight sheet just for XMRig, start it and then add the GPUs to it.

Trying a switch from cpuminer-opt to xmrig-new. Why does it only use 6 cores and doesn’t post the 12 threads like cpuminer-opt does? Is it still using all threads? Are there some config settings that could be shared please. Thank you all.