More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

WiFi settings not remembered on reboot

Hello! So far I have enjoyed working with Hive but I have been having issues with WiFi. I have a Netgear A6210 which I installed the drivers for from Github. USB adapter is detected and I am able to connect to wifi using the wifi command and entering SSID/PW, but when the machine reboots, it doesn’t attempt to connect to wifi at all, I have to re-enter everything manually. Using my Windows PC I added the settings to wifi.txt like so…

WIFI_SSID=“xxx”
WIFI_PASSWORD=“xxx”

… but it doesn’t seem to be registering those settings on boot. Is there a way to disable ethernet and force wifi? or is there another file I can edit? Really don’t want to have to manually enter the info on every reboot.

Any help is greatly appreciated! Thanks!

2 Likes

I have the same issue, after restarting the rig. the wifi will not reconnect. need to manually run “wifi” again to get network id, and password to reconnect. Anyone has this issue and able to solve it? please post it here.

I’m having this issue on one of my rigs. Have to run “wifi SSID PW” command on every reboot to reconnect to my wifi. I have other rigs on wifi without this issue except one. Tried HiveOS versions 0.6-203 to 0.6-217. Can anyone with more experience with Linux chime in? Thanks.

Try enable “Power cycle” option in worker > settings.

This make hiveos shutdown and power on all the system again, and now usb ports are loaded completly.

withou this option enabled, maybe hiveos enable ports in a ghost mode, that cause wifi problem.

think you need to set the /etc/network/interfaces.d/wlan0 file