Increase your income with Hive. Invite your friends and earn real cryptocurrency!

When I plug a 5th GPU, HiveOS doesn't connect to my rig

Hi HiveOS forum,

I have 5 NVIDIA GPUs (2 from ASUS 1660 Super, 2 from MSI 1660 and 1 from EVGA 1660 Super).

Strangely when I plug the 5th GPU HiveOS is not able to connect on my rig. See photo:

I tried these things without success:

-Changing the PCIE slots
-enabling maintenance mode (don’t load drivers) in the Settings tab.
-rebooting many times
-running ‘nvidia-driver-update --list’ command and installing different previous stable driver versions. ( I tried 455.45.01, 460.67, 450.102.04. and 460.56)

When I try to plug one GPU at the time HiveOS recognize them all it’s just when I plug the 5th GPU that last one is not recognized.

Hope someone can help me.
Thank you

To follow up with my issue.

I have tested each GPU one by one. I mean I have unplugged from the motherboard and the power supply the other GPUs and only kept one GPU plugged with HDMI cable to see the terminal worker on the screen.

4 GPUs work perfectly fine on HiveOS but when I test one by one that GPU:

GeForce GTX 1660 5941 MB · MSI - Samsung GDDR5 ·

is not working on HiveOS. When I only plug that “faulty” GPU on my mining rig, the worker terminal open (on my screen plug with HDMI on the GPU) but in the terminal when I try to type something it’s frozen, nothing appears. Then suddenly, on HiveOS, on the worker page, it seems the connection get lost.

Looking forward to hearing from you.
Thank you

Did you ever figure out what was causing the solution? I am having the exact same problem it seems. Doesn’t seem to matter which gpu I leave for last.

Yes for my system I found the solution.
In your BIOS try these settings:

PCIe Speed : Gen2 (For all the PCIe slots)
4G Decoding : Enabled
CSM Support : Disabled
HD Audio: Disabled (this one is optional I think)

What Didz said

Awesome thanks! I had seen something like that in another post so I’m going to try that tonight.

Edit: it worked, thanks a ton.

You’re welcome!
I remember it took my one week of trials and errors, I asked tons of questions on HiveOS Telegram and other forum and finally someone told me to try that hehe. Now I always apply these sittings when I build a mining rig.

1 Like

Great! Thanks! It helped a lot, I was having this problem, changed it in the BIOS solved my problem.

1 Like

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.