Increase your income with Hive. Invite your friends and earn real cryptocurrency!


  • (NEW) VerthashMiner v0.6.2 (open source miner for both AMD&Nvidia platforms for mining VTC/VertCoin on new algorithm ‘verthash’)

Hi, how to install verthashminer? it is not on the miner list when creating new flightsheet ?


I tried earlier and I’m seeing the same thing, Verthashminer doesn’t show up in the miner dropdown when creating a flight sheet.

I’m too lazy to figure out how to make it work as a custom miner so I just connected to the worker w/ SSH and downloaded and manually ran verthashminer in a screen session for now. It works except of course no statistics show up in the hiveos web interface.

verthashminer is now in the miner list thanks !! :+1:

Hi stef942,
Do you have any idea of the commands about mining verthash?

nothing special to do : create a new flight sheet , use verthashminer, add --all-cl-devices for amd cards or --all-cu-devices for nvidia, decide heavy file location and thats it

hi stef942,

any idea how to set the WorkSize at 0, BatchTimeMs at 500 and OccupancyPct at 100


When is update releasing for v0.7?
Getting lots rejected shares on the old .6.2

1 Like

Yea same issue with rejected shares

Same for me2. Please update to v0.7 asap =)

Hi, tried version 0.7, cannot start miner :confounded:

[2021-03-03 07:35:56] INFO Found 5 OpenCL devices.
[2021-03-03 07:35:56] WARN Failed to initialize CUDA. error code: 100
[2021-03-03 07:35:56] WARN CUDA devices will be unavailable.
[2021-03-03 07:35:56] INFO Verthash data file has been loaded succesfully!
[2021-03-03 07:36:02] ERROR Verthash data file verification has failed!
[2021-03-03 07:36:02] ERROR Miner configuration failed! (Errors: 1, Warnings: 0)

edit: ok i found the reason, if you have the same error, delete data file (verthash.dat) located in /home/user/tmp and re-create it

1 Like

I’m trying to get my 280Xs to mine with the verthashminer 0.7.2, but nothing yet.

My 290 is mining OK, but not the 280s.

Anyone that had better luck, could you point me to the right direction here.

(Kernel ver. = 5.4.80-hiveos)

export GPU_FORCE_64BIT_PTR=1
export GPU_MAX_HEAP_SIZE=100

Type this in rig.conf, that could help! I had the same issue with an HD 7950.

Hello @stef942, how do you create a file on the hive os drive for heavy file location?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.