Increase your income with Hive. Invite your friends and earn real cryptocurrency!

VertHashminer troubles

For some reason I can’t seem to prevent VertHashminer from running on both AMD & Nvidia cards.
If I specify in miner setup “–all-cl-devices” Hiveos overrides that and adds “–all-cu-devices” no matter what settings I try to enter.

Even tried to edit /hive/miners/verthasminer/0.7.2/miner.conf to prevent using Nvidia cards, still no dice.
Changed owner to root and write protected the file, no matter, still same result.

Haven’t figured out a solution to this yet, running HiveOS 0.6-203@210415.
Any help would be greatly appreciated!


I’m experiencing the same issue. I only have a single AMD card next to 5 Nvidia cards, and specifying the cl device index also fails to solve the issue. No matter what, every card in the machine starts mining when I launch VertHashminer.

Hope someone gets it figured out soon! Until then, back to RVN…

1 Like

How do you specify the cards? --cl-devices <and then?>

1 Like

I tried with and without quotes in lots of places

–cl-devices 0
“–cl-devices 0”
–cl-devices “0”
“cl-devices”: “0”

(I just figured I’d try that last one since that format works with T-Rex and I was getting desperate). If I remember right, all of them threw some type of “incorrect parameter” errors except for the first one, which proceeded to mine with all 6 cards (5 nvidia, 1 AMD). I did run it once with --device-list in the parameters to confirm the index, which worked as expected. Cuda devices had indices 0 through 4, the single OpenCL device (also) had index 0.

So if we’re assuming “–all-cu-devices” gets added by HiveOS automatically, I guess it makes sense that it was filtering my cards down to all of my Nvidia cards, and also my only AMD card at index 0.

I did not try adding a “–cu-devices 0” in there as well to see if it would use 1 AMD card and 1 Nvidia card, but maybe I could try that later just to see what happens. My AMD card is an old 4gb that can still turn a profit on RVN and VTC, while the Nvidia cards are all mining ETH (which I don’t want to change).

1 Like

My situation is very similar, have 2 Nvidia cards with 8GB+ vram and all AMD cards are 4GB, kind of annoying as I haven’t found a way to circumvent hiveos implementation of how the write the config for the miner.

1 Like

I’m experiencing the same issue. I Edited miner.conf, but the change was deleted and the line “–all-cl-devices - all-cu-devices” appeared back

I submitted an e-mail to [email protected] detailing the issue. Hopefully the devs notice it and will be able to issue fix.

Support got back to me already, they identified problem and will rectify in next update. Great work from their part with the response time, gj hiveos team!


This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.