Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Urgently need original BIOS of ASUS 5700xt Dual EVO with Samsung Memory

Hi there,

I bricked my ASUS 5700xt DUAL EVO :frowning: and I need the original BIOS of this card but with Samsung Memory.

I have the original BIOS with Micron Memory but it is not working :frowning: because my bricked card has Samsung memory.

I would be very thankful if someone could upload the file anywhere and send the link here. Or send it to my email: [email protected]

See un techpowerup

I have tested all ROM files there. Could not find any one that works with my card.

Visit It

I tried this BIOS and I changed the Sub Vendor to 1043 and the Sub ID to 5AD so that it matched my ASUS 5700XT DUAL EVO and it is not working.

Push on AMD un MPT down Id
Id change

Sorry un RBE no in MPT

I tried your suggetion and pushed on AMD button in RBE but still not working.

The flashing is done correctly but after I reboot into HiveOS the system see the card but amd-info command reports follwing:
Cannot find DRI instance for pci:0000:10:00.0

On Windows when opening the GPU-Z it sees the card but it shows 0 GB in the Memory section and also 0 MHZ in the frequency section.

When flashing the card with the same bios model(ASUS RX 5700 XT Dual Evo) but with micron memory the system does not see the card at all and I need to reflash the card using the CH341A programmer with either the BIOS file you suggested or another MSI BIOS that I have with Samsung memory.

You gpu un motherboard or Riser ?
Try change riser

Try BIOS MOD by Kiawpqe:
try it

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.