Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Unusual Low Hash Rate in Hive OS for first 3 GPU's on a 10 GPU Mining Rig (RX580)

Hi everyone,

I am facing an issue mining in Hive OS with an unusual low hash rate for GPU 0, GPU 1 and GPU 2. These are all AMD RX 580’s.

The remaining GPU’s (GPU3, GPU4, GPU5, GPU6 etc.) also drop to around the same hash rate every so often for a short time but then shoot back up to approx. 27 M/H.
I’m using the following overclock settings: Cclock 1000, mclock 2160 for the 8GB cards and cclock 1000 mclock 1760 for the 4GB Cards.

I was able to get a constant stable hash rate of around approx. 27 M/H for most of these cards in Windows and also do not get my cards overheating to 70C+ like they do in Hive OS.

But for some reason when using Hive OS i can’t get the hash rate for GPU 0, GPU 1 and 2 to go up to what it should be where it’s almost like the cards overclock settings are not being applied as they’re hashing at such a low rate.

I’ve tried the following already myself:

+setting the overclock settings and assigning to the rig, rebooting rig, still same result.
+setting up an overclock profile assigning it to the rig, rebooting rig, still same result.
+using the claymore config override with my overclock settings, rebooting rig, still same result.
+Tried changing overclock settings and underclocking as well, then rebooting the rig with no change in the Hash rate for GPU0, GPU 1 and GPU 3.

Has anyone else faced this issue? Does anyone have any recommendations of things to try to fix this issue?

Many thanks!

I think it depends on motherboard or BIOS settings that you use. You didn’t mention what setup you have.
I personally have had similar issue when tried to switch PCI-E x16 port to Gen1 mode in BIOS Setup. And surprisingly I got low hashrate for the cards in other ports. You can check PCI-E mode with “lspci -vv” command. Type it in ssh-console or HiveOS’s web-based “Linux Shell Execute” section. You’ll get detailed report about all PCI devices in your system. For every video-card look on the line like this:

LnkSta:	Speed 5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-

This means PCI-E Gen2 (Speed) x1 (Width) mode. If you have “Speed 2.5GT/s” - that is PCI-E Gen1. And that is the reason of low hashrate. But again, check speed for video-cards only, because for ethernet/audio devices Gen1 is OK.

Thanks alf, I will check this.
I have a B250 Mining Motherboard and recall i might have set these up as Gen 2 setting in the BIOS settings where I can see that some cards are having a speed of 5GT/s where others seem to have a speed of 2.5 GT/s.
I think i might have set the incorrect BIOS setting here as the Mobo is Gen 1 :S…

Simply gong into the motherboard bios, (Gigabyte B360 HD3 bios update 12a) and changing the settings from Gen1 to Gen2 fixed the problem for me.

Thanks alf