Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Unable to boot on new build

Hello. I am writing as I have a relatively new build that is not completing the OS initialization.

This build works fine with Windows. Prime95, FurMark, Memtest86 and CrystalDiskInfo reflect no hardware issues.

When I attempt to boot into HiveOS, the initial outputs are shown on screen, but the OS load fails at various points in the process. There is no consistent last entry in the logging.

The only consistent thing that looks amiss is the following:

[FAILED] Failed to start Load Kernel Modules.
Please see 'systemctl status systemd-modules-load.service' for more details.

Things I have tried:

  • Enabling/disabling CSM.
  • Enabling/disabling Windows 10 features (slider between Windows 10/Other OS)
  • Booting the OS from a flash drive, an SSD in an enclosure, an SSD via SATA, an NVMe, and an NVMe in an enclosure
  • Using the beta OS image on the series of enclosures and tests above


  • Intel Core i7-12700K
  • G.SKILL Ripjaws V Series 32GB (2x16GB)
  • GIGABYTE Gaming GeForce RTX 4090 OC-24GD

Unfortunately, nothing has worked. I am unable to get the machine to properly boot HiveOS.

I was able to discover that perhaps there is an issue with 11th/12th gen Intel chips for an older kernel version:

Is this issue still relevant and if so, how should I apply the fix (ibt=off) to any applicable files so I can attempt to boot with this CPU?

Thank you and let me know if any more diagnostic information can be useful to you.

Have you verified the drive boots in any other pc? Are you using the latest stable image or beta image?

Yes - the stable image and the beta both boot up regularly in my standard machine, which has a 5800X3D inside. Neither image works on the test machine with the 12700K inside.

Interesting. On latest bios? Have you tried removing the gpu to see if it boots?

The BIOS was one revision out of date, but updating did not solve the issue - nor did removing the GPU from the system. It will still lock up on a random instruction and fail to continue the bootup.

Let me know what additional diagnostic can be provided on my end!