Increase your income with Hive. Invite your friends and earn real cryptocurrency!

[TTM] Failed allocating swap storage

I’m trying to configure a 12 gpu AMD RX rig with HiveOS. I flashed HiveOS on a 64gb ssd, but when I try to run Phoenix miner I receive this error:

[TTM] Failed allocating swap storage
[TTM] Buffer eviction failed

I tried disabling some of the cards, but there’s no difference.

Linux kernel and AMD driver version?
What GPUs ?

Take a look at the screenshot. I get this error even if I try to mine with the first gpu only.

I have similar problem, details on screenshot. I’m using TeamRedMiner - sometimes it starts mining and quickly freeze, or freeze while starting. Phoenix/Claymore won’t even start mining.

Config: just 2 RX470 4GB, HiveOs on 8GB pendrive.

When I start with single card (no matter wich one) it mines without a problem.

EDIT: I forgot one thing. It worked for a few hours on old (few months) version of HiveOS, but I foolishly upgraded. Then tried clean image from web, no difference.

Is there any update on this topic? I have the same issue with three different separate rigs.

I tried HiveOS Beta on my different rig, with 2x RX 5700 XT. It kind of worked, but from time to time (minutes-hours) same error. I’ve tried different pendrive (32GB, resized partition to use all), no difference. Then I added second stick of RAM (so now it’s 2x4GB) and the problem is gone. I have no idea what’s going on, because now system reports 5,9GB mem free, so it’s not using extra memory, but this is the only change I’ve made.

I don’t know Linux or Hive os so I have no idea if it’s only a coincidence or there is a bug regarding memory/virtual memory.

I have Asrock H110 with 13 GPU (5700 XT) and I have not fully solved it but here are a few things that helped:

  • biggest help for reducing OOM killer: switched to lolminer 1.14 seems to work real good, 1.15 is not as good as 1.14 in my experience
  • Increase RAM to 16GB (sometimes OOM killer will still start but it certainly reduces)
  • disable CSM in BIOS
  • Try different PCIE speeds in BIOS, gen1, gen2, AUTO (mine is most stable with AUTO)
  • HiveOS only uses 7GB on hard drive, you can expand to whole hard drive (disk-expand), HiveOS does not have Swap file by default, but I have created a 32GB Swap file on root drive, I am still testing so not sure if it totally removes the problem yet.
  • I found that the longer you run the miner the more RAM is eats, one time after 45 mins if you run “free -h” command, it says my RAM was at 12GB used out of 15GB (16GB physical RAM). Then one time it ate into my Swap file by about 2GB.
  • I also had to change the vm_overcommit_memory setting to 2 and vm_overcommit_ratio to 99 but not totally out of the OOM killer yet, so I will keep you posted.

My most stable setup was 12 GPU on HiveOS beta 5.6 with v157 and Lolminer 1.14 ran for 20 hours no error
CSM disabled
PCIE speed was AUTO
16GB ram
0GB swap file

But when I put on 13th GPU, the OOM killer came back…

Now I am testing the stable build which is 5.0.21 kernal with v172 and AMD driver version 20.30 on 13 GPU.

I’m having the exact same issue on one of my rigs all of a sudden.

[TTM] Failed allocating swap storage
[TTM] Buffer eviction failed

Any progress on figuring out what’s causing this?

Any update on this thread?
i have the same problem
H81 pro BTC
4gb ram

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.