Increase your income with Hive. Invite your friends and earn real cryptocurrency!

T-rex miner not starting up

Hello there,
I got a new 3070 rig but when I try to let it run T-rex I get an error and it doesn’t boot.
The error is :
t-rex exited (exitcode=127), waiting to cooldown a bit

Skipping miner log rotation due to execution time < 30sec

/hive/miners/t-rex/ line 18: t-rex: command not found

If I run phoenixminer it works with no problems, does anybody know what I’m doing wrong please ?


trex miner might be the problem , remove it and install it again.

Thanks for the reply, sorry for my noob question but how do I do this exactly ? :relaxed:

when you log in to the console. there is a list of options available for the HiveOS.

hpkg [remove miners noinstall] - Hive package manager. Specify option to remove

with this “hpkg” i think you will be able to uninstall all.
if with this same command you cant install it after removal, you can try switching in the flight sheet between miners and it will auto install it again.

i just tried the hpkg command and its very nice.

with hpkg remove miners - it automatically removed all miners that i have installed and then installed my current miner that i currently use.

Hello, thanks for your help.
I tried to run the command but I get this:

Uninstalling packages

  • hive-miners-phoenixminer
    E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

  • hive-miners-phoenixminer-5.6d
    E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

  • hive-miners-t-rex
    E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

Updating repository
Hit:1 InRelease
Hit:2 InRelease
Reading package lists… Done
Checking miners default installation

Looks like it’s not working the way it should.

Did you try sudo dpkg --configure -a

I tried messing around with the commands but nothing seems to work, I’m new to this so don’t know if I’m running them ok.
‘sudo dpkg’ does nothing, by doing dpkg only I get a list to force stuff but when I try nothing happens…
I must be doing something wrong.

Thanks again

root@miner_1:/# dpkg --force-help
dpkg forcing options - control behaviour when problems found:
warn but continue: --force-,,…
stop with error: --refuse-,,… | --no-force-,…
Forcing things:
[!] all Set all force options
[*] downgrade Replace a package with a lower version
configure-any Configure any package which may help this one
hold Process incidental packages even when on hold
not-root Try to (de)install things even when not root
bad-path PATH is missing important programs, problems likely
bad-verify Install a package even if it fails authenticity check
bad-version Process even packages with wrong versions

This i the most I get to seeing something that looks like configure, but cannot seem to run it

possible that I need to upgrade to latest nvidia driver ?
The version I have now is: 460.67

Tried updating to latest Nvidia driver and tried running not the latest version of T-rex but still the same error.

Does anybody have an idea how to fix this error please ?
Still haven’t found it, thanks.

Its not due to nvidia driver. The script that tries to run has some error in it or missing file. Remove miners and add them again or try different miner and see if it works

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.