Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Strange Bluetooth error with HIVEOS

Album here:

I am building second rig for gpu mining; I am using an intel 10100 cpu and GIGABYTE Z590 AORUS MASTER (yay newegg bundle).

upon starting hive os, i was getting an uninterruptable stream of error messages (see album):

[ T134] Bluetooth: hci0: Reading Intel version information failed (-22)
[ T134] Bluetooth: hci0: Intel Read version failed (-22)

I was unable to do anything else, attempting to type would be interrupted by the error message which pops up every second.

I flashed the bios to the latest version and hardwired to network, and now the rig is mining with the test card, but the error message keeps popping up every second. aside from the preset commands (by pressing up on the arrow keys), its not possible to do anything in the terminal as anything you type gets interrupted by the error messages. As you can see in the images, the system is mining away, but i would like to get this fixed before adding more cards. I did not see any bios options to disable bluetooth, nor do i have any bluetooth items connected to the rig. Also, strangely enough, it does not appear to be in the hiveos desktop enviroment, the terminal is full screen and i dont know how to minimize, if possible at all.

I also tried using hiveos flashed on an ssd, and known good copy of hive os from a flashdrive, both give the same error message/ non desktop enviroment.
Anyone come across this issue before? How do i fix it?

Have you tried disabling Bluetooth in the BIOS?

Along with everything else which is not necessary for mining.

Have you tried the beta image?

I have tried- in the sense of looking for anything bluetooth related in the BIOS. there are no bluetooth options listed. I did try to disable everything that had the option to be disabled, and still got the same issue.

Some of my boards couple the WiFI and Bluetooth on the same chipset. Have you disabled WiFi?

As Keaton suggested, you are likely running into driver issues with your newer motherboard. They may be in the beta hiveos images.

I’d shut down everything anyway, get back the board resources.

I just tried the beta image; same issue persists.

Unfortunately i see no option to turn off wifi in BIOS. i can turn off onboard lan, but that has no effect on the issue.

Hi, did you fix it?
Same problem with z590

nope, unfortunately the only solution was to switch motherboards. its an issue with the Bluetooth 5.2 on some of the newer boards.

thanks, finally working with other linux OS, waiting new kernel in HIVEOS

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.