Increase your income with Hive. Invite your friends and earn real cryptocurrency!

[SOLVED] Help : Total Ram ONLY 3396mb out of 4gb

How can I make more ram available ?
Free -m command shows -
Mem :

Total - 3396

Used - 756

Free - 2213

Shared - 33

Buff/cache - 427

Available - 2365

My CPU is G4400, Ram is 4gb DDR4

Do you have iGPU enabled?


Also BIOS settings may contain option which disable using RAM which over 32-bit addressing memory space
I have not seen this for long time but old motherboards may have this option.

Is igpu integrated intel gpu ? Because my monitor is connect to MoBo so it’s probably using it. I am successfully mining for months using this setup - monitor connected to MoBo with 12*1050ti but out of curiosity I checked it today to see how much ram is available. My monitor has only vga port.

I can’t find igpu but in BIOS- Chipset- Graphics Configuration- Internal Graphics is on Enabled

Yes iGPU it’s Internal Graphics. It seems like some parts of RAM dedicated for using by iGPU.
You can try disable iGPU or find and reduce dedicated RAM for iGPU

There is a Primary display option which is on IGFX but there are options for PEG and PCIE too. As I will disable Internal Graphics should I set primary display from IGFX to PCIE or set it to AUTO ?

AFAIK usually we have 3 options in BIOS in modern MB

  1. PEG = x16
  2. PCI/PCIE = it’s can be any PCI/PCI-E slot
  3. iGPU = Internal graphics
    2 and 3 in most cases not suitable with NVidia cards.

Solved. Disabled igpu and now its good.

1 Like

close topic as solved