Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Setting OC with mixed 10 and 30 series cards

Hi there,
I have a system with 2x 3070’s and 3 x 1080 Ti’s. I was facing crashes every hour or 4 and finally realized that the core clock was absolute, not offset (I only have a 10 series rig on HiveOs, all other 30 series were previously on Windows machines).
Because I have the 10 series with the ethPill, and only offsets support, and the 3 series with absolute clock support, is there a way to get my system running stable? How would I create an OC profile for this mixed rig?
Does having the ethpill running cause issues with the 30 series cards? Can it be applied to only the 10 series?
I have an MSI z-390 A-Pro mobo
1600w Gold EVGA PSU
8gb RAM

use the pill cmd parameters to specify which GPUs get the pill. in that way you can set it only to the 1080s if by any chance it messes with the 3070s. So check the 1080s IDs and set GPU 0,1, 2 use the pill or whatever the IDs are.

Thanks rkulov. I have tried that with no luck. I’ve also tried removing the 3070’s so only the 1080’s are in the rig, and I am actually still getting freezes with no OC, no pill.

skip the pill. its busted in hiveOS… use memtweak 4 instead, or mt6 . --mt wont affect 30 series cards. and will replace the pill for 1080 & Ti cards. if your not using 1080’s or Tis then pill will cause issues on all other 10 cards also.

if your using trex you can add mt in the flightsheet under


Thank you. As mentioned previously to rkulov, I have tried the mem tweak with no luck already. I’ve also remove the memory tweak, with no OC, ensured the pill was turned off, no fan profile, and it is still freezing up on me.
oddly enough, I tried no OC with the pill, and no OC without the pill (still no mem tweak), and my hashrate didn’t change (but still froze). I wiped the ssd and started over, but no changes yet.
I ran these cards on another rig with a high OC and pill with 0 issues for months. Something seems to be wrong with the system, but I can’t tell what. I ran 18 hours with no OC and just the pill. Then no pill, no OC, no mt, and it ran for 4 hours before freezing.

you say you have run them on other rig. have you compared the driver versions, OS versions, Kernel versions, so you can see if there is a difference with your current setup?

I can confirm both rigs are running on Kernel 5.4.80-hiveos, Nvidia Linux driver 465.31, OS Version 0.6-204@210608. Only difference is a different rig with different components.

you need to run trex for memtweak to work. are you on trex or another miner?

I only use T-rex.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.