Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Second gpu onwards not working - uvd not responding!?

I just got a used rig from my friend that has been offline for 2/3 years (he said it worked pretty fine back then). It consists of:

  • 8x RX580 8gb PowerColor
  • Asus Prime Z270-AR
  • Intel Pentium® [email protected]
  • 4gb of ram (2133mhz)
  • 2x Corsair CX750m power supply
  • Sandisk 16gb flash drive
  • 2x PSU Corsair CX750m

When I run only one gpu, HiveOS starts fine. When I plug the second GPU onward, I start to get the error “UVD not responding, trying to restart the VCPU” as can be seen on the image (

I tried to change the PCI-e Auto, Gen1 and Gen2 (only didn’t try Gen3). Also tried to edit /etc/default/grub to change the line to GRUB_CMDLINE_LINUX=“radeon.modeset=nomodeset” (also tried radeon.modeset=0 and just “nomodeset”).

Not sure if there is another config that can be made to solve this.

Any clued to help!? Ty a lot!


  • I’m testing with only a single PSU and 2 or tops 3 gpus, so the power cables come all from the same PSU.
  • All gpus are with original factory BIOS.


Tests already made, without managing to boot more than two gpus:

  • Hive OS update to latest stable version: done.
  • Motherboard battery change: done.
  • Change the riser of the second gpu for a new one: done.
  • Change from 4gb of ram to 8gb of ram: done.
  • Update the BIOS: done.
  • Config in the BIOS:
    • System Agent (SA) Configuration > VT-d > Disabled: done.
    • System Agent (SA) Configuration > DMI/OPI Configuration > DMI Max Link Speed ) Gen2: done
    • System Agent (SA) Configuration > PEG Port Configuration > PCIEX16_1 > Gen2: done.
    • System Agent (SA) Configuration > PEG Port Configuration > PCIEX16_2 > Gen2: done.
    • System Agent (SA) Configuration > PEG Port Configuration > PCIe Spread Spectrum Clocking > disabled: done.
    • PCH Configuration > PCI Express Configuration > PCI Speed > Gen2: done.
    • Onboard Devices Configuration > HD Audio Controller > disabled: done.
    • Onboard Devices Configuration > M.2_1 Configuration: [Auto][SATA mode][PCIE mode] > PCIE Mode: done.
    • Onboard Devices Configuration > M.2_1 Bandwodth Configuration > X4: done.
    • APM Configuration > Restore AC Power Loss > Power ON: done.
    • Boot > Fastboot > Enable/Disable (tried both): done.
    • Boot > Post Delay Time > 0 sec: done.
    • Boot > Above 4G Encoding > Enabled: done.

Trying to put another 4 gb (is must ) of ram to system… and if the problem consist we talk again.

Just tested with 8gb ram. Same error. =/

make sure you have done this settings like a video above…

Yup. Done all this BIOS configs and tried with some others as well. Still nothing. =/ Updated the post with the tests already made.

Image of the motherboard:

You know what version of bios grachics cards they have? Maybe your friend have them bios flashed allready with a bios before 3 years ? in your situation i restore the default bios in one by one and test it … if you check all ready all the above maybe your problem is your bios of your cards… and check also if have the latest hive os stable version…

Well, flash the bios is one thing I really haven’t tried. I’ll ask and report.

Ask your friend if he allready done something like this… you can down load your bios fro your cards from

be sure for your vendor and your model…

1 Like

Got an answer from my friend… He says he bought the GPUs new and never flashed them. So… original bios on all of them.

With a 750w, assuming it is not defective, it would support two gpu plus mobo, proc, memory and two risers… right!? lol…

four gpus in one psu is not a problem (check at the wall with power meter to be sure about aberage… your connections to the risers must it with 6 pin power pin…(not sata cable) this cards with default bios take 120-130 watts …
Put one gpu in first pcix 1x not 16x (the bigger one ) flash ssd drive with the latest stable version of hive os (it has the drivers for this gpu’s) make the power connection with 6 pin to risers … after this you sould be running … then add another gpu (put in your motherboard one by one and check if has a problem…

After this (working condition) you must flash your cards for better performance and lower power consuption… (all this at second step…)

Also check your flash drive…(16 gb ) is small… put ssd or old disk …with sata connection …


I am really bugged by this rig. I found out that the problem is not exactly plugging the second gpu onwards, it is actually with 7 of 8 gpus that came with the rig. I plugged other two gpus that I had and they worked fine along the only gpu of the 8 that worked.

What is bugging me is that when I got the rig, there were only one gpu plugged directly on the mobo and there were other 7 gpus plugged in risers. And these 7 gpus are the ones that are not working.

I’m still trying to understand what is happening, trying different arrangements. But I’m guessing there is a good chance that I’ll return the rig to my friend…

Have you tried enabling 4G and setting PCI Speed to Gen 1 for both settings? (in the MB Bios)

Yup, 4g is enabled on all tests and I tried Gen1, Gen2 and Gen3. Now currently sitting at Gen2.

1 Like

Did you ever get it running?

I second that: did you ever manage to get to the bottom of it and resolve this?
I’ve got the same problem with one of my AMD RX 580 4gb and don’t know what to do. It used to work and stopped showing this UVD error all of a sudden

I solve the problem reinstalling hiveos.

I reinstall hiveos remote, with this command:
hive-replace --list