Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Sapphire RX580 8GB Issues

Hi all,

I’m having issues with my Eth rig as 2 of my 3 cards wont mine no matter what bios or settings I use, this may just be something simple as I am new to the mining scene but if anyone has any idea why this is happening please let me know.

GPU0: Sapphire RX 580 8GB Nitro+ (Samsung) Working
GPU1: Sapphire RX 580 8GB Nitro+ (Samsung) Failed
GPU2: Sapphire RX 580 8GB Pulse (Micron) Failed

MB: Asus Trooper H110 D3
CPU: Intel Core i3 6320 3.9Ghz
RAM: HyperX 8GB
SSD: Corsair 120GB

Note: I have used the rig in windows and tried flashing stock bios versions from Techpowerup for both cards but still no joy, also they show up in windows and drivers installed fine however neither have a video output, also tried swapping risers around with the working GPU but still the same.


What miner are you using? What coin?

I’m mining Ethereum with phoenixminer

That sure sounds right. What kernal and version of OS for hive? Are you using the current stable build ( 5.021.201105) and [email protected] or newer? I had some real bumps lately with my AMD cards but the latest builds have them working good again. I hope this helps.

I’ve not built a windows based rig, Linux only at this time, but would be interested in trying.

I’m running [email protected] 5.0.21-200905-hiveos, i have tried other versions but doesn’t seem work even on older versions, one thing to note is that i noticed when putting either card as the primary gpu for windows they start to atrifact slightly and get worse then crash windows, i have tried the stock bios for both and changing clock speeds but nothing,
I also tried using a usb programmer for bios chips and flashed the bios that way and seems to flash fine to the eeprom so i dont think its a bios issue.
Another thing i notice is that for the card that works the memory says 8192 MB and the cards that dont work say 8192M so i’m not sure if this can help identify my issue.

Are you using the VBIOS from Hive? What are your overclock settings? Are they the same per card?

When you say VBIOS from Hive what do you mean? I had the stock bios but that doesn’t seem to work, then tried my modded bios and also one from tehcpowerup and still not working, for my overclock settings I use the best preset for an RX 580 8GB mining ETH which seems to work fine on my other rig and my working card in this rig.

On the cards tab, you can download VBIOS for your cards, save these to your vbios storage. These bios are by Hiveon, make sure you have a backup. Once downloaded check your vbios storage to be sure the files there. You can flash the vbios from the card tab.

All i can see under cards is VBIOS versions that i have uploaded, before I put these on here is was empty, I can’t see another tab for community or HiveOS uploaded bios versions anywhere? the only other download option is to download the bios directly from the card that is in use?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.