Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Sapphire Nitro RX580 4GB undervolting

Hello, I just booted HiveOS, setup everything but my rig of six Sapphire Nitro RX580 4GB cards won’t undervolt. I am using gpu clock 1200 and memory clock 1975 (most stable for me) in order to get 170mhs for eth mining @ 920w at the wall. If i use memory state 1 i do get the desired undervolting of 720w at the wall but the hashrate drops to 150mhs. I am unable to make them work at 170mhs with a power draw of 720w which would be ideal, even better than with windows (770w) and simplemining os (820w).
Is there anyone with the same problem, can anyone help?

hi we have the exact same rig :). I am new to hive os but so far i put 1150 as gpu clock, 2000 for memory (except one card 1850 :frowning: ). doing 170 like this. but because one card is only doing 25 compared to the 29 of the others. I will try to reflash the bios on that one.

What are your settings bt ? Memory state in hive is at 4 here


Well, I now have a different bios which allows me to better overclock the cards and also increase the hashrate. I now run the gpu at 1150 and the memory at 2050 both set to 900mv and they’re stable while drawing a bit more power. I get 30mhs on elpida and 29.3 on hynix which totals at 178mhs.
For cryptonight I get 5300hs, 900hs for elpida and 865 for hynix. For eth under windows there is a total gain of 3mhs while drawing 100w less at the wall.
The best I got so far while preserving the hashrate is 700w at the wall for cryptonight and 900w for eth.
Under windows the power draw is still 100w less, tried it using a fully updated win10 and latest 18.2.1 amd drivers set to blockchain compute. The overclock and undervolt seem to work best if set from claymore, no msi afterburner needed. I should mention I got a few blue screens under windows as often as I get gpu hangs under hiveOS.
The memory state I leave it blank under the oc profile from hiveOS, I guess it defaults to memory state 2 from the two (1 and 2) possible. The one you say you use is probably from the gpu and is called core state (I use 3 there). My bios is at 900mv for the memory. The trick for linux seems to be the memory state.

Do you have the Bios that you modified to? on which you get 30Mhz

Yes I do. Here it is.
Tell me how it goes…