Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Ryzen CPU Temperature Monitoring

It would appear that monitoring Ryzen CPU temperatures is not possible with the current HiveOS kernel. I realize the majority of people focus on GPU’s, but I do also mine ETN on my CPU and it makes me a bit nervous that the temp can’t be monitored. Is there any thought being given to a 4.11 based kernel with the Ryzen sensors modules included?

It’s been added now in 0.5-51.

To install the AMD Ryzen temperatures (k10temp kernel module), update to that version or later and SSH into the box or locally run the command:


I’ve installed this k10 mod - but when I run 8 instances, it shows as 8 temps, and then the second set of temps as 20C more. Can a person set a temp alert for GPU and one for CPU? Or is there a way to adjust the temp to drop the 20C variance?

I know it’s running at 65C, not 85C based on other monitoring, so it’s a software glitch on the second set of CryptoNight processes I use for SMP to fully use the processor up.

I’ve had this on 5.0-51 and 5.0-52.


Have the same problem! On Ryzen I have 16 degrees which is not real. Tried to update M/B bios, Update the Hive and install k10temp module.

Is there any solution?

My Ryzen 9 shows all temperatures = 95°. Anyway to get the actual temperatures?


Mine shows 0°. (Ryzen 5600x)

i have AMD Ryzen 5 5500 AES
B450 TOMAHAWK MAX II (MS-7C02) Micro-Star International Co., Ltd (H.70 04/01/2022)
but same problem CPU temp show zero please any one help me to solve this problem

Anoar any luck resolving?

what cpu do you have?


You need 6.xx kernel or newer to see the full sensors on the ryzen 7000. If youre only cpu mining you can try this test image:
hive-replace -y[email protected]

1 Like

Thx for that but am both cpu and gpu mining

Hi keaton_hiveon,
This img is no longer available (I know it works for me because I tried it a few months ago but I can’t find it yet).
Can you please share it again ?
Thank you in advance.

just use the beta image instead now

There was an issue that was resolved with Kernel 6.4 where EPYC Milan’s Tctl was reported to be about 50℃ higher, but now the normal value is also reported. thank you.