Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX580 Hynix 8gb wrong PCIE count problem

Hello, I am new here. I want to apologize in advice for my bad English.

Early I installed hiveOS and used it normal and everything works fine on my rig. Now I bought new but same motherboard (H81M Plus) because old one had bad integrated hdmi.

I just remove old and connect everything same in new MB. Finished bios setup (Gen2, above 4g decoding etc… same settings as on old one) same hiveOS ssd… I have 4 x RX580, but rig booted with only 3 GPUs showed. After reboot it shows all 4 GPUs but for last it shows that it’s connected to 5th pcie (my motherboard have only 4 pcie slots) and for last GPU it doesn’t shows temps and fan stats.
Also unknown memory is showed.
“amd-info” shows first 3 GPUs stats and “Cannot find DRI instance for pci:0000:05:00.0” error

Here is screenshot if it can help you to understand me.


When screenshot is captured rig was shutdown, that is why there is no temp and fan stats… look at pcie for 4th card… 5th !!!

I tried:

  • Flash fresh hiveOS on ssd
    //Didn’t helped

  • hive-replace command and choosing beta (dual bios) image
    //Didn’t helped

  • Updating drivers to 19.30 from 19.20
    //Didn’t helped

  • Disconnect 4th gpu riser and boot
    //3 gpu work fine but last(3rd) fails (0.0 mh/s) on phoenixminer after few mins, as I have bad OC settings (but all 4 gpu worked great with same OC settings on old MB)

Please for help :slight_smile: and thanks in advice.

Hello Miner,

My advice in your situation is… Firts fix the OC settings in your rig , Second , Change bios mode of your motherbord Gen 1…

This is my advice for you…
Best Of Luck…

Looks like your clocks are a little high make the 2200 2000
Make the 1130 1100 and make 850 and 900 to all 850.

yeah the temps will freak out if the clocks are too high

I would reccomend to check the riser.

Also memory controller voltage should be 800 no need more. You have set core voltage 850. This voltage can support around 1150 core clock or even more. I would recommend removing the power limit set by you. This setting doesnt work for these card. Switch on aggressive undervolting l. Use amdmemtweak – Ref 30.
Mem clock might be also a bit more. Test with 2150.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.