Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX580 Flash VBIOS didn't work!?


I have a Powercolor RX580 8GB which I just got from a friend. I had one gpu that was hashing really high (33mh/s) but almost all invalid shares, so I decided to mod the bios. Here is what I did:

  • Downloaded the bios from whithin HiveOS.
  • Opened the file with polaris, used one-click and saved on ANOTHER FILE (the original remained the same).
  • Uploaded the modded bios to the rig.

Now phoenixminer doesn’t mine with this gpu, it starts the other gpus but this one keeps 0mh/s.

Tried to upload the original unmoded file. All the same. Tried to upload the unmodded bios from another card (same model), nothing. Tried again the original bios file from this gpu, nothing.

Any, any help would be appreciated.

Phoenixminer log:
2021.01.27:20:04:19.474: wdog GPU2 not responding
2021.01.27:20:04:19.474: wdog Thread(s) not responding. Restarting.


I had the same problem with my RX 580 card. I did a bios mod, like you did, and something went wrong. I could not find the original bios for that card, i lost it somehow. But i did find the stock bios on this webbpage:

Try to download the bios without mod and see if it works.
if it doesn’t work, try another bios from that site

hope it helps

1 Like

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.